• Revista PROGRAMAR: Já está disponível a edição #53 da revista programar. Faz já o download aqui!

M.offspring.R

[Resolvido][Problema] Asus P5B e suse 10.2

20 mensagens neste tópico

Boas.

Recentemente comprei uma ASUS P5B Intel P965 SK775 e até aqui tudo bem. O problema e quando vou instalar o OpenSuSE 10.2... Ou seja, inicia o ambiente grafico mas depois passados x segundos vai para o modo texto com a seguinte mensagem:

Could not find the OpenSuSE installation CD.

Activating manual setup program

Passado isto vai para o modo de texto. Neste modo escolho a opção instalar o sistema (se não me engano no nome), e escolho a fonte de instalação, ou seja, o DVD, mas ao escolher o sistema manda-me outra mensagem:

Unable to mount the CD-ROM

E daí não passa....  :D

Tava eu todo contente com o Core 2 Duo, mas estou vendo que fiz ma compra no que toca a motherboard... (ja testei outras distros, como por exemplo, Ubuntu 6.10, Ubuntu 6.06, Fedora Core 6, Debian e nada...). Estou pensando em comprar uma placa pci (MATCH PLACA PCI/IDE UDMA133), mas não sei se será boa compra, pois tenho medo de gastar 15€ e dp não der para instalar...

PS: Não sei se será relevante mas tenho a seguinte configuração:

ASUS P5B Intel P965 SK775

C2D E6400 (@2.13)

1gb ddr2 667 da Kingston

IDE 160gb (onde tento instalar o linux, juntamente com o penuria)

SATA 300gb sata II (disco de backups)

Aguardo uma resposta.

Cump.

M.offspring.R

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

epá...

eu tenho uma msi 975xPU e o 10.2 tb se revirou d tal forma q me embrulhou os controladores todos

para ja a unica solução q encontrei foi instalar suse 10.1 minima e dps actualizar para 10.2. nao é solução q me orgulhe mas... esta 10.2 tem dado bastantes problemas, dai eu migrar para gentoo :confused:

cumps e fiquem bem

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Mas eu nao consigo por nenhuma distro, dai eu ter perg.

Sera se eu comprar a tal placa PCI, conseguirei instalar laguma distro na boa??

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Temia que isso me acontecesse no portátil, mas felizmente não aconteceu. De qualquer forma, aqui está a solução:

The "CD not found" error before installation

If you have a Core 2 Duo-capable motherboard and are getting an error message about the installer not being able to find the CD/DVD after you have already booted from it, the problem is likely with your IDE controller. In some modern motherboards, the parallel ATA controller has been taken out of the chipset and moved to a third-party drive controller. That third party is JMicron, and this problem most famously occurs in the Asus P5B motherboard, though other brands and models can be affected as well.

First, it will help to do a quick workaround in your BIOS. Press the Del, F1, or F2 key to get into your system BIOS just after powering it on. There should be a message somewhere on the screen that tells you which key to press; if you are not sure, press all three repeatedly and you're sure to get there. Somewhere in the BIOS setup you should see an option for the JMicron drive controller ("Onboard Devices" in the P5B BIOS menu). Set it to AHCI mode, then save and exit the BIOS setup utility.

in SuSE PT

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Acabei de testar... mas sem sucesso  ;) maldita board... Sabia k dava raia a nível da rede, não fazia eu ideia k era com o controlador IDE.

Só resta uma solução, a que pode não ser a mais correcta, mas será se eu comprar a tal placa PCI (placa esta que adiciona mais dois canais IDE) conseguirei instalar o linux??

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Já tentaste com a nova kernel que saiu ontem? :biggrin:

A melhor solução era usares Gentoo ou Arch Linux ou uma distribuição do género que te permite ter os últimos packages. Isso de certeza que vai ser corrigido, por isso a minha sugestão é que mesmo que esta nova kernel não resolva o problema, espera um pouco que na nova beta isso já deve estar resolvido. ;)

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Já tentaste com a nova kernel que saiu ontem? :biggrin:

A melhor solução era usares Gentoo ou Arch Linux ou uma distribuição do género que te permite ter os últimos packages. Isso de certeza que vai ser corrigido, por isso a minha sugestão é que mesmo que esta nova kernel não resolva o problema, espera até um pouco que na nova beta isso já deve estar resolvido. ;)

o problema é que o kernel do CD's de instalação demora algum tempo a ser actualizado, por isso não sei se o Gentoo ou o Arch lhe resolve o problema...

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Já tentaste com a nova kernel que saiu ontem? :biggrin:

A melhor solução era usares Gentoo ou Arch Linux ou uma distribuição do género que te permite ter os últimos packages. Isso de certeza que vai ser corrigido, por isso a minha sugestão é que mesmo que esta nova kernel não resolva o problema, espera até um pouco que na nova beta isso já deve estar resolvido. ;)

o problema é que o kernel do CD's de instalação demora algum tempo a ser actualizado, por isso não sei se o Gentoo ou o Arch lhe resolve o problema...

Isso também é verdade, o Arch deve ter um kernel mais recente na versão 0.8 alpha, mas também podes tentar o Fedora 7 ou o Ubuntu 7.04. :)

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Estou vendo que só posso usar o linux emulado pelo vmware em Windows...  ;)  :down: (sempre é melhor que nada)

Fica uma pessoa contente de montar 1 core 2 Duo e experimentar o linux e depois da isto...

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Porque não fazes imagens dos discos numa partição Windows e instalas a partir daí? Além de (em princípio) resolver o problema, a instalação também se torna muito mais rápida. Foi como eu fiz as minhas instalações do SuSE 10.2.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Posso tentar, mas nunca fiz dessa maneira, não faço a ideia como seja, podes dar-me umas luzes?

Cump.

M.offspring.R

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Logo à noite tento explicar. Não é complicado, mas também não é propriamente directo. Vou sair agora pra trabalhar, e logo se chegar vivo a casa tento dizer qualquer coisa ;)

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Obrigado pela dica, já testei e passa da parte onde eu estava "encravado"... Mas agora tenho outra dúvida.

Eu tenho 2 discos (1 IDE de 160 (Onde quero instalar o Linux) e outro SATA de 300 (Disco de backups)) o que acontece, é que o sistema só me detecta o disco de 300 e não o de 160, pois a minha intenção é instalar no disco de 160 e não no de 300. Como faço para que o sistema só me detecte o de 160??

Cump.

M.offspring.R

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

se calhar é outra vez um problema com os controladores IDE...

PS: não seria melhor instalar o Linux no SATA, visto que o desempenho é melhor do que o do IDE?

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Se não me engano, nas novas kernels tens uma opção legacy-ide ou uma opção parecida... ;)

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

se calhar é outra vez um problema com os controladores IDE...

PS: não seria melhor instalar o Linux no SATA, visto que o desempenho é melhor do que o do IDE?

Eu quero deixar o SATA longe da "guerra"...

Tenho aqui um cabo em que posso ligar qualquer hardware por IDE (Disco ou leitor CD/DVD) e ligar depois por USB, se eu tentar com o cabo terei acesso ao disco de 160?

Edit: Ja testei a cena o cabo... mas sem sucesso. ;). Estou vendo que so consigo usar o linux emulado com o vmware em windows  :down:

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Temia que isso me acontecesse no portátil, mas felizmente não aconteceu. De qualquer forma, aqui está a solução:

The "CD not found" error before installation

If you have a Core 2 Duo-capable motherboard and are getting an error message about the installer not being able to find the CD/DVD after you have already booted from it, the problem is likely with your IDE controller. In some modern motherboards, the parallel ATA controller has been taken out of the chipset and moved to a third-party drive controller. That third party is JMicron, and this problem most famously occurs in the Asus P5B motherboard, though other brands and models can be affected as well.

First, it will help to do a quick workaround in your BIOS. Press the Del, F1, or F2 key to get into your system BIOS just after powering it on. There should be a message somewhere on the screen that tells you which key to press; if you are not sure, press all three repeatedly and you're sure to get there. Somewhere in the BIOS setup you should see an option for the JMicron drive controller ("Onboard Devices" in the P5B BIOS menu). Set it to AHCI mode, then save and exit the BIOS setup utility.

in SuSE PT

Boas.

Ja consegui que o sistema me detecta-se o disco de 160GB. Agradeço a ajuda que tentaram dar.

Obg TheDark pela dica, mas esqueces-te do resto, ou seja disto:

Boot from the openSUSE 10.2 CD 1 or DVD. You'll still get the same message, but now you're better enabled to work around it. Press Enter to get past the error message, then choose your language in the following screen. That will bring you to the main menu. Use the down arrow key to select the Kernel Modules option and press Enter. In the next screen press Enter again to select the default option for IDE/RAID/SCSI Modules. In the long list that follows, find both the JMicron and the Generic IDE drivers, select them, press Enter, then press Enter again when you're asked for special options to pass to them. You will have to do this twice -- one time for each driver. When you return to the kernel module screen, use the Tab or arrow keys to select Back, and press Enter. That should put you back into the Main Menu. Now select the option for Start Installation or System and press Enter, then select Start Installation or Update and press Enter, and lastly select the CD-ROM as the source and press Enter. The normal graphical installation procedure will commence.

If the above does not work, write down installation source mirror addresses from the link in the installation source section below and use them to install openSUSE over FTP. The only difference in the procedure will be to change the above instructions to select FTP instead of CD-ROM as the source.

Pois esta parte também é importante.

Resumindo a solução e esta:

1. Ir a BIOS e modar o modo de IDE para AHCI

2. Fazer o boot ao DVD do suse

3. Procurar a opção (Kernel Modules Option)

4. Procurar a Opção IDE/RAID/SCSI Modules e encontrar/seleccionar JMicron

5. Carregar em Enter

6. Voltar para o menu principal e seleccionar a opção Start Installation

Apartir daqui é normal :P

Amanha quando instalar coloco aqui com mais detalhes a instalação.

Cump.

M.offspring.R

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Como não consegui resistir até amanha para instalar o linux, deixo aqui todos os passos que dei até a instalação começar. Então cá vai...

01. Ir à BIOS, separador Advanced e depois Onboard Devices Configuration

02. Ir até ao JMicron SATA/PATA Controler e colocar a opção AHCI

03. Guardar as modificações na BIOS e sair

04. Dar o boot ao DVD do OpenSuSE 10.2

05. Neste passo aparece a tal mensagem a dizer que não consegue encontrar o CD-ROM, então carregamos em OK, escolhemos a língua que queremos para o nosso sistema (neste caso PT-BR) e carregamos em OK novamente.

06. No menu principal, vamos para a opção acima (Módulos Kernel (Driver de Hardware))

07. Carregamos na primeira opção (Carregar Módulos IDE/RAID/SCSI)

08. Na lista que aparece, escolhemos o pata_jmicron+Jmicron PATA e carregamos em OK

09. No quadro que aparece, carregamos em "enter" e esperamos uns segundos. Irá surgir uma mensagem que diz "Módulo carregado com êxito" (obviamente que a língua da mensagem pode variar de acordo com o passo nº 5)

10. Voltamos para o menu principal, carregando em cancelar

11. Escolhemos a opção Iniciar Instalação ou Sistema

12. Seleccionamos a Iniciar Instalação ou Actualização

13. Chegamos ao último passo. Escolhemos o CD-ROM e está feito. Agora é prosseguir com a instalação.

Ao fim de muitas tentativas la consegui por o OpenSuSE a instalar. Vamos lá ver se não dá mais problemas...

Cump.

M.offspring.R

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!


Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.


Entrar Agora