• Revista PROGRAMAR: Já está disponível a edição #53 da revista programar. Faz já o download aqui!

Sota

FF vs IE

24 mensagens neste tópico

boas pessoal, não sei se este é o melhor sitio para colocar esta duvida mas aqui vai:

Eu crei um template em photoshop e depois dividi aquilo em slices para poder colocar a informação em seguida começeia et adicionar texto com includes isto ficou muito bonito no firefox mas quando vi no IE os tamanho que defeni nas pagina que fiz includes mudaram e ficou tudo disfurado.

o site é www.sabot.btuga.net/home.php abrindo cons diferentes browsers podem ver o que quero  dizer.

Eu pensei em fazer uma adaptação para IE e outra para firefox mas n exite outra maneira mais facil :S 

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

assim à primeira vista parece que queres meter uma página dentro de outra...

o problema não é do IE, é mesma da página que está mal feita.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

se colocares cá o código dá mais resultado...

se vir o código através do ie, aparece o inicio da tabela, depois css, depois mais linhas da tabela, mais css, etc...

se vir o código através do ff, penso que seja o html correcto...

por isso, convinha colocares cá o ficheiro php para se poder descobrir o porquê desta discrepância de códigos...

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

para começar, altera o css referente aos tamanhos das fontes... tens definido como small e cada browser trata o small de modo diferente...

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

como já referi antes, estás a meter uma página dentro de outra!!!

tens as tags 'html', 'head', etc. repetidas dentro de tabelas. essas tags só aparecem uma vez em cada página.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Então para resolver passa apena por tirar as tags a mais ou tenho mesmo de arrajar outra forma de fazer?

e se tenho já agr podiam me dar umas luzes :D

Obrigrado

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Então para resolver passa apena por tirar as tags a mais ou tenho mesmo de arrajar outra forma de fazer?

e se tenho já agr podiam me dar umas luzes :D

Obrigrado

no início da página tens as tags 'html', 'head', 'body', etc. e essas são para ficar.

nos outros sítios onde essas tags aparecem só deves deixar ficar aquilo que está dentro das tags 'body'.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Pesso desculpa por tanta duvi parva mas penso que esta é a ultima  :biggrin:  quando eu adiciono logo na primeira linha <!DOCTYPE HTML PUBLIC..... ele deforma-me  a pagina toda pensei que com o erros corrigidos voltasse ao normal mas não voltou  :D

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Pois axo que me esqueci de referir no IE yah mas no firefox não  :D

Obrigado :biggrin:

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

por acaso estou a usar o Safari :D

não estou a ver qual é o problema no firefox...

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

o site correcto é www.sabot.btuga.net/home1.php a outra que mensionei no inicio está com o codigo html não valido sorry pelo lapso :wallbash:

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

o site correcto é www.sabot.btuga.net/home1.php a outra que mensionei no inicio está com o codigo html não valido sorry pelo lapso :wallbash:

é esse que eu estou a verificar... e no Safari aparece direito.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

tão não sei porque já exprementei em tres pc's com firefox e em todos está deformado:S

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Pois e isso só me acontece qd mete no inicio da pagina <!DOCTYPE.... :S

Quando usas essa declaração o browser entra no Strict mode.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Se toda a gente se habituasse a fazer as coisas com HTML ou XHTLM e CSS válido já não se deparavam com problemas como este.

É tão simples e ao mesmo tempo é de apreciar uma página sem erros na linguagem.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Se toda a gente se habituasse a fazer as coisas com HTML ou XHTLM e CSS válido já não se deparavam com problemas como este.

É tão simples e ao mesmo tempo é de apreciar uma página sem erros na linguagem.

por acaso a minha página está feita com xhtml e css válido (pelo menos a parte que foi feita por mim) e mesmo assim dá problemas com a porcaria do IE (mais na versão 6, mas também na 7).

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Sim, eu estou ciente disso, daí que existem dezenas de coisas que tem que se alterar (principalmente em CSS).

(O IE explorer será sempre o aquele cancro...)

Mas certamente se começares com uma linguagem válida, então as correcções básicas a fazer para o correcto funcionamento

no IE são já conhecidas, logo é mais fácil.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!


Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.


Entrar Agora