• Revista PROGRAMAR: Já está disponível a edição #53 da revista programar. Faz já o download aqui!

AriOps

Onde arranjar o GLIBC_2.4

18 mensagens neste tópico

Boas!

Estava a instalar o Beryl e quando ia a executar o manager deu-me este erro:

/usr/bin/beryl-manager: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.4' not found (required by /usr/bin/beryl-manager)

Alguém sabe onde posso arranjar o GlibC 2.4?

Cumps  :P

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

o local mais correcto para instalar isso penso que é no '/usr'. mas por defieto é instalado no '/usr/local'. a opção '--prefix=/usr' (do 'configure') permite-te mudar isso.

esse programa que precisa da glibc é instalado como? se for a partir do código fonte, certamente que existe uma opção no 'configure' para indicar a localização da glibc.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

o local mais correcto para instalar isso penso que é no '/usr'. mas por defieto é instalado no '/usr/local'. a opção '--prefix=/usr' (do 'configure') permite-te mudar isso.

esse programa que precisa da glibc é instalado como? se for a partir do código fonte, certamente que existe uma opção no 'configure' para indicar a localização da glibc.

pois não sei, tenho de ver...

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

bem ao menos já consegui ver que não corre a partir de código fonte... é mesmo um executável

aliás, são 3 os executáveis do beryl que não consigo correr por causa do glibc:

daniel@daniel-desktop:~$ sudo /usr/bin/beryl-manager

/usr/bin/beryl-manager: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.4' not found (required by /usr/bin/beryl-manager)

daniel@daniel-desktop:~$ sudo /usr/bin/beryl

/usr/bin/beryl: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.4' not found (required by /usr/bin/beryl)

daniel@daniel-desktop:~$ sudo /usr/bin/beryl-xgl

/usr/bin/beryl-xgl: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.4' not found (required by /usr/bin/beryl-xgl)

Imagem em anexo de quando tento editar... já instalei o glibc para o usr, para o usr/local e não deu, tenho de reiniciar a máquina? mesmo que não seja preciso vou fazer isso...

Já não sei como vou fazer isto  ;)

o glib que saquei foi este:

http://ftp.gnu.org/gnu/glibc/glibc-2.4.tar.bz2

Cumps :)

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Sim, tens que fazer reboot à máquina. E não vais longe ao tentar editar um executável ;)

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Sim, tens que fazer reboot à máquina. E não vais longe ao tentar editar um executável ;)

Pois eu sei, era para ver se era executável ou não mesmo.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Sim, tens que fazer reboot à máquina. E não vais longe ao tentar editar um executável :)

Pois eu sei, era para ver se era executável ou não mesmo.

lol, bastava veres o mod dele ;)
0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Assim por alto estás a usar que sistema operativo? É que de certeza que existem tutoriais de como instalar o beryl e ai esclarecias todas as tuas dúvidas ;)

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Assim por alto estás a usar que sistema operativo? É que de certeza que existem tutoriais de como instalar o beryl e ai esclarecias todas as tuas dúvidas ;)

Ubuntu 6.06 (Dapper)

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

é assim estive a seguir novamente o tutorial do xgl nesta distro e quando executo esta linha:

  sudo apt-get install xserver-xgl libgl1-mesa xserver-xorg libglitz-glx1 beryl emerald-themes

dá-me este erro:

  xserver-xgl: Depende: libc6 (>= 2.4-1) mas 2.3.6-0ubuntu20 está para ser instalado

Mas no synaptic não tenho nenhum libc6 maior que 2.3.6...

Existe alguma maneira de corrigir isto?

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Não metas XGL. Se puderes põe AIGLX.

Tens os mesmos efeitos mas ficas com um sistema mais estável.

Acho que aqui diz como se faz.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

estou a seguir este guia:

http://www.guiaubuntupt.org/wiki/index.php?title=Aiglx_Beryl_Edgy

e chego a uma parte onde dois repositórios não existem, aí está parte do problema talvez:

--14:24:12--  http://compiz-mirror.lupine.me.uk/quinn.key.asc

          => `-'

A resolver compiz-mirror.lupine.me.uk ... 80.77.247.17

Ligando a compiz-mirror.lupine.me.uk|80.77.247.17|:80... ligado.

HTTP requisição enviada, aguardando resposta... 404 Not Found

14:24:13 ERRO 404: Not Found.

sudo wget http://ubuntu.compiz.net/quinn.key.asc -O - | sudo apt-key add -

--14:24:50--  http://ubuntu.compiz.net/quinn.key.asc

          => `-'

A resolver ubuntu.compiz.net ... 195.14.0.203

Ligando a ubuntu.compiz.net|195.14.0.203|:80... ligado.

HTTP requisição enviada, aguardando resposta... 404 Not Found

14:24:50 ERRO 404: Not Found.

gpg: nenhum dado OpenPGP válido encontrado.

Isto a adicionar as chaves de autenticação...

alguém tem repositórios adicionais?

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Finalmente consegui! :)

Para quem quiser a solução é a seguinte:

1º visitem este link:

http://packages.ubuntu.com/edgy/base/libc6

e instalem o pacote e todas as dependências necessárias

2º Se tiverem problemas com os pacotes .deb, façam isto:

Para uma dependência quebrada, conserte-a ou use:

    # dpkg --ignore-depends=pacote1,... -i arquivodopacote.deb

    # dpkg --force-depends -i arquivodopacote.deb

    # dpkg --force-depends --purge pacote

    # dpkg --force-confmiss -i arquivodopacote.deb  # Instala arquivo de configuração faltando

Cumps ;)

Vou agora reiniciar isto, se funcionar eu posto um screenshot no tópico do costume :)

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!


Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.


Entrar Agora