• Revista PROGRAMAR: Já está disponível a edição #53 da revista programar. Faz já o download aqui!

Nazgulled

Testem-me este pequeno utilitario sff

17 mensagens neste tópico

Durante o desenvolvimento do Network Switcher deparei-me com um problema no que toca ao activar/desactivar as placas de rede do sistema. Já tenho o código todo implementando no Network Switcher mas suspeito que apenas funcione em versões do Windows em Inglês e apenas para o 2000 e XP, mas isto, terá de mesmo ser assim; se a Microsoft já não suporta os antigos Windows, porque hei-de eu suportar? :) Mas o facto de apenas funcionar no Windows em Inglês é capaz de ser chato e queria a vossa ajuda para testar noutras versões que não em inglês.

A maioria, é que capaz de ter o Windows em Português, mas eu agradecia que mais do que uma pessoa testasse no Windows em Português o que vou pedir a seguir. Se por acaso alguém tiver outra versão do Windows que não Português nem Inglês agradecia, caso seja possível, que também testassem lá. Escusado será dizer que para o que pretendo que testem, têm de ter no mínimo uma placa de rede instalada e configurada.

O Network Switcher vai implementar a funcionalidade deste utilitário: http://channel9.msdn.com/Photos/ZippedFiles/158556_ToggleNic.zip

Para o testarem façam o seguinte:

1) Abram uma linha de comandos (cmd.exe) e naveguem até à pasta onde se encontra o utilitário (depois de descomprimir o zip obviamente).

2) Verifiquem o nome da ligação (ou de uma das ligações) da placa de rede (ie: "Local Area Connection" ou "Wireless Network Connection", para a versão em inglês costuma ser assim).

3) Executem o comando passando como parâmetro o nome da ligação entre "" (ie: ToggleNic "Local Area Connection").

4) Postem aqui o resultado que aparece na linha de comandos e digam em que idioma do Windows foi testado.

P.S.:  Caso o comando funcione, a ligação que vocês escolheram irá trocar de estado. Ou seja, se estava activa, vai-se desactivar, se estava desactiva, vai-se activar. Para reporem o estado em que se encontrava, voltem a executar o mesmo comando.

Agradeço desde já a contribuição de quem me ajudar com este pequeno teste...

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

@karva

Qual o nome que aparece no teu painel de controlo para as ligações de rede? escreve aqui tal e qual como está no painel de controlo (com acentos e maiúsculas)

@Triton

No inglês eu já sei que funciona, mas obrigado na mesma.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Win XP SP2 pt

Comando: ToggleNic "Ligação de rede sem fios"

Resultado: "Network connections folder not found"

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

@karva

sim, mas não era a isso que me referia, e agora o mesmo aconteceu ao Hipnoted...

O nome "Ligação de rede sem fios" está dentro de um "directório" não esta? Se clicarem no botão para ir para "cima", vão ter ao painel de controlo... eu quero o nome dessa "directório" e não da ligação em si... Isto porque o programa esta procurar pela pasta "Network Connections" dentro do painel de controlo, e como vocês tem o windows em português, o directório não é encontrado. eu quero saber esse nome, para alterar o utilitário, postar aqui a versão alterada para voltarem a testar.

O nome para o tal directório, é configurável no Network Switcher, por isso, isso não é problema. O problema está noutro aspecto que quero que testem, mas para isso, preciso de saber o nome do directório (onde as ligações estão guardadas) em português (não esquecer, tal e qual com os acentos e maiúsculas que tiver).

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

não era suposto isso acontecer... :S que comando executaste para aparecer esse erro?

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

mas não faças isso, faz como inicialmente, abre a linha de comandos e executa o comando como anteriormente... só tens de ter em conta que o nome do ficheiro, não é mesmo...

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

É pa... que estupido que eu sou... peço desculpa. O problema é que no zip que eu criei, esqueci-me de anexar o ficheiro Interop.Shell32.dll que é necessário... Junta os 2 (ToggleNicVB.exe e o dll numa pasta e depois experimenta outra vez o que diz no primeiro post e diz-me o resultado. O dll está no zip do ToggleNic inicial, do primeiro post.

Desculpa lá o trabalho...

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

mesmo pondo algo a frente do nome da ligacao, dizme sempre

No enable or disable verb found

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Exacto... Era isto que eu realmente queria testar e que eu suspeitava que assim fosse. lá vou ter que adicionar mais umas opções as preferências do programa e criar uns documentos bem explicadinhos em como configura-los correctamente.

Isto, se realmente terminar a aplicação, porque deparei-me com um problema que não faço ideia como vou resolve-lo, e se não conseguir por a funcionar, então a aplicação não tem razão de existência :S

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!


Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.


Entrar Agora