• Revista PROGRAMAR: Já está disponível a edição #55 da revista programar. Faz já o download aqui!

cjulio

Utilizar Webservices da AT

7131 mensagens neste tópico

 

Em ‎09‎-‎03‎-‎2017 às 15:10, antseq disse:

Enviar GT para servidor de testes da AT está a dar :

"A ligação subjacente foi fechada: Erro inesperado ao enviar"

 

Instalando o certificado no windows funciona Ok.

mais alguém tem esta situação!?

Obrigado

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Boa tarde pessoal,

 

Alguém faz invocações aos webservices da AT a partir de um servidor AZURE (ou num site alojado no azure)?

 

Abraço

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
1 hour ago, mjjferreira said:

Boa tarde pessoal,

 

Alguém faz invocações aos webservices da AT a partir de um servidor AZURE (ou num site alojado no azure)?

 

Abraço

Boas estou tentando mais ainda não consegui os que eu quero que funcione

Até agora estou com o arrendamento e as guias de transporte a funcionar em C# ASP.NET. Não estão no azure mas estão em servidores virtuais AWS amazon. Se quiseres podemos partilhar ideias/conhecimentos. Eu não percebo nada de java por isso ainda tenho umas duvidas sobre os outros webservices.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Boas,

 

Alguém me sabe explicar porque raio é que no ambiente de testes, em que usamos o certificado 'TestesWebServices.pfx' com a senha 'TESTEwebservice' de um momento para o outro começou a dar o erro na invocação dos webservices:

The underlying connection was closed: An unexpected error occurred on a send.

 

Usamos ASP.NET e C#.

 

Só consigo ultrapassar esta situação e ter as coisas a funcionar se instalar manualmente o certifica TestesWebServices.pfx no windows na store Personal (Pessoal).

 

Em produção, nada disto acontece?

Porquê?

Editado por mjjferreira
0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
5 horas atrás, PeterBaga disse:

 

Instalando o certificado no windows funciona Ok.

mais alguém tem esta situação!?

Obrigado

Também gostava muito de saber!

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
3 horas atrás, mjjferreira disse:

Boas,

 

Alguém me sabe explicar porque raio é que no ambiente de testes, em que usamos o certificado 'TestesWebServices.pfx' com a senha 'TESTEwebservice' de um momento para o outro começou a dar o erro na invocação dos webservices:

The underlying connection was closed: An unexpected error occurred on a send.

 

Usamos ASP.NET e C#.

 

Só consigo ultrapassar esta situação e ter as coisas a funcionar se instalar manualmente o certifica TestesWebServices.pfx no windows na store Personal (Pessoal).

 

Em produção, nada disto acontece?

Porquê?

Para quem não se quer preocupar com a instalação manual no windows, pode no código adicionar isto: 

                X509Certificate2Collection certCollection = new X509Certificate2Collection();
                certCollection.Import(certificate, "TESTEwebservice", X509KeyStorageFlags.DefaultKeySet);

                X509Store certStore = new X509Store(StoreName.My, StoreLocation.CurrentUser);
                certStore.Open(OpenFlags.ReadWrite);
                certStore.AddRange(certCollection);
                certStore.Close();               



                request.ClientCertificates = certCollection; //add collection to web request

 

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!


Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.


Entrar Agora