Ir para o conteúdo
  • Revista PROGRAMAR: Já está disponível a edição #57 da revista programar. Faz já o download aqui!

thoga31

Problemas na instalação do Windows 7

Mensagens Recomendadas

thoga31    611
thoga31

Camaradas, aqui vem um problema que me está a queimar a mioleira.

Tenho aqui o DVD de instalação do Windows 7 que pode ser executado a partir do XP. Corri o DVD, e ele começou a instalar numa unidade diferente para poder manter o XP.

Como avisou o instalador, o PC reiniciou a meio da instalação.

E agora, com o DVD lá metido, o PC arranca mas fica a piscar o cursor no famoso ecrã negro. Não anda nem desanda, não lê o DVD, nada.

Já está assim há mais de uma hora.

O que raio se terá passado aqui?

Cumprimentos,

Com votos de um Bom Ano Novo. :)

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
thoga31    611
thoga31

Já foste à BIOS?

Nunca me atrevi a mexer nessa maravilha em 14 anos de "carreira", confesso. :)

O que é suposto eu ver lá?

Entretanto consegui fazer boot com a minha PEN que tem o Ubuntu 10.10 - eu bem me parecia que me ia dar jeito um dia - e instalei-o. Consigo arrancar só com o Ubuntu, e no boot dele aparece, além das opções do Ubuntu, "Windows Vista (on /dev/sta1)".

No disco C, onde está o XP, está tudo intacto. No disco D, onde estava a ser instalado o 7, estão já as pastas do Windows, mas ainda estão outras da instalação, sendo que, segundo me apercebi, a finalização da instalação será mover a pasta "WINDOWS" e os ficheiros de boot para a raíz da D: que estão, neste momento, noutra localização.

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
acao    19
acao

boas

deves ir à bios e ver se está configurada para XP e altera para outros.

porque não formatas tudo e instalas o win7 e se precisas do xp instalas o xp virtual!

pS: já estou a ver muita confusão de pastas no disco D:, normalmente quando se tem 2 sistemas operativos divide-se o disco em três para reservar um para dados.

cumps

acao

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
thoga31    611
thoga31

Não me vou dedicar a ver isso na BIOS... a instalação do Windows 7 não está concluída, nem nunca estará, e não sei até que ponto não mexeu algo no XP (leia-se, o boot do Windows). E tenho algum receio de fazer "trampa". :)

O DVD que tenho do Windows 7 é um daqueles onde colocamos a correr directamente numa versão anterior do Windows e faz a actualização dessa forma.

Não me importava de o formatar directamente para Win 7, mas não me apetece gastar 200€ num SO, e não quero piratarias aqui no meu PC. :P

Tenho ali um CD com o Windows XP e faço a formatação, e depois corro de novo o Win7 Upgrade, a ver se tenho sorte desta vez.

Entretanto, o Ubunto 10.10 vai-me permitir gerir as partições e recuperar os dados para o meu HDD externo. Vou fazer 3 partições, que uma de 70GB e a outra de 400GB não faz lá muito sentido. :)

A não ser que tenham outra sugestão.

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
bioshock    170
bioshock

Perguntei porque deves ter o disco a arrancar em 1st drive. Colocado em 1st drive, assim que reinicias o pc, se estiver lá algum CD, ele vai ler de imediato.

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
thoga31    611
thoga31

O problema é que este DVD não vai fazer nada se o PC arrancar por ele, porque isso já eu tentei. De outra forma sem alterar a BIOS, é certo, mas é a mesma coisa e nada faz.

O meu diagnóstico é o seguinte:

  A instalação necessitava de reiniciar o PC várias vezes, e ao primeiro reset houve uma falha qualquer que agora não arranca nem o XP nem mais nada. Só o Ubuntu arranca porque é o único cujo boot está "intacto" (so to speak), bem como o próprio SO.

A minha proposta de resolução:

  No Ubuntu, fazer backup dos ficheiros e redifinir as partições de uma forma "mais-melhor", porque a forma actual é algo patética. Formatar por completo a unidade C e limpar os "restos" da instalação do 7. Pegar no CD do XP que tenho ali encafuado algures e instalá-lo. Tento de novo a instalação do 7, mas desta vez como upgrade e não alongside.

Já estou farto de dar aqui voltas e de ver sempre o mesmo cursor pisca-pisca no belo fundo preto. Este caso já não vai lá com remendos, se não fico com um trapo de remendos e não um SO "intacto".

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
thoga31    611
thoga31

Vários dias depois, venho dizer que resolvi o assunto.

Experimentei as vossas propostas, e nada. O sistema tinha ficado corrupto por alguma razão.

Formatei com o XP, refiz as partições e estou agora mesmo no Windows 7, instalado alongside com o XP numa partição "ao lado". ;)

Agora estou a repensar se mantenho o XP, pois esse é pirateado (ups), e tenho sempre o aviso de que fui vítima de falsificação (como se não soubesse disso :confused:), enquanto que o 7 é original.

Obrigado a todos pela vossa atenção!

Cumprimentos,

thoga31

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
softklin    12
softklin

Já com o problema resolvido, acho que fizeste bem em dar uma oportunidade ao Windows 7, e vais ver que vale a pena. Em particular na tua situação relativamente às licenças, tenta fazer a transição para o Windows 7, transferindo os teus documentos, e programas que usas regularmente. Tirando o caso de alguns programas e jogos muito antigos, em princípio deve funcionar tudo bem. Verifica também se todo o hardware funciona bem, senão tenta procurar no fabricante drivers atualizados. Enfim, os procedimentos habituais que já deves saber.

Se notares que algum programa não é compatível, podes sempre recorrer à virtualização, usando o Windows XP Mode (se tiveres o W7 Professional, ou superior), ou o Virtualbox (mas neste último voltas ao mesmo problema de necessitares de uma licença, para estar legal), e instalas lá os programas necessários.

http://www.microsoft.com/windows/virtual-pc/download.aspx

http://www.virtualbox.org

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
thoga31    611
thoga31

Olá, @softklin.

Por acaso corri o Windos 7 Upgrade Advisor antes do "desastre". Disse-me que a placa gráfica suportava o Aero, mas agora o 7 diz-me que não suporta -  o tema que tenho não é o Aero mas sim o Basic. Nem os screen savers correm precisamente à pala disso. Tenho de ir verificar a existência de novas drivers. Se a placa gráfica aguenta segundo a análise mas não corre na realidade o Aero, então é porque, actualmente, a driver é da idade da pedra. B)

Vou manter o XP, mesmo que "ilegal". Só pretendo correr lá o Sim City 4 para as férias e mais uma ou outra coisa, e está muito bom para o meu pai - ele não se quer actualizar, por mais que eu lhe explique que o XP, em 2014, caput! Não vale o trabalho de legalizar o que é velho e que mal vou usar. :)

O XP Mode... Vou investigar o caso. B)

Obrigado, mais uma vez. :)

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
thoga31    611
thoga31

Bem, e lá vem mais um problema. Tentei actualizar para o SP1 pelo Windows Update, e nunca dava. Fiz o download do SP1 no site da MS, e deu-me um erro a instalar. :-\

Fiz o download que me recomendou, uma Ferramenta de Preparação, e o erro a instalar o SP1 persiste.

ERROR_SXS_ASSEMBLY_MISSING(0x80073701)

Alguém me consegue traduzir isto por miúdos? Como resolvo o problema? A MS não tem mais soluções para mi, já... :lamo:

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
acao    19
acao

boas

presumo que não fizeste a instalação do 7 de raiz, aconselho-te a faze-la .

mesmo sendo um dvd de upgrade penso que dá para instalar.

faz assim:

mete o dvd no gravador, pc arrancar por dvd e instala , se não passar a passwod por ser upgrade, abortas a instalação nem que tenhas que desligar o pc, e voltas a instalar que na segunda vez já passa.

cumps

acao

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
thoga31    611
thoga31

Eu instalei exactamente colocando o DVD em arranque. Nada de upgrades. :)

Agora andar a reinstalá-lo de novo? Minha Nossa! Nunca mais tenho isto como deve ser... :)

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
Flinger    50
Flinger

Creio que devem ser as celebres teorias da microsoft :)

O problema original podia derivar de a instalação do 7 ter reescrito o bootloader. Acontece o mesmo se instalares o Linux, e de seguida instalares o XP noutra partição... a microsoft não gosta muito de multi-boot. Como a istalação do 7 deu raia, lá foi tudo à vida :)

De qualquer forma dá uma vista de olhos a esta tabela, retirada do MSDN:

Use this chart to determine whether you should do an upgrade or custom (clean) installation.

Upgrade From: Upgrade To:

                                                Windows 7 Professional Windows 7 Ultimate

Windows XP, all editions         Custom install required Custom install required

Windows Vista Starter         Custom install required Custom install required

Windows Vista Home Basic Custom install required Upgrade available

Windows Vista Home Premium Custom install required Upgrade available

Windows Vista Business         Upgrade available         Upgrade available

Windows Vista Ultimate         Custom install required Upgrade available

Windows 7 Home                 Custom install required Custom install required

Ou seja, o melhor é mesmo fazeres uma instalação de raíz. Tenta o truque que o acao te disse, a ver se funciona. Para usares o XP, experimenta o XP mode (acho que só está disponível da versão professional para cima, mas não tenho a certeza). Caso contrário, podes usar uma máquina virtual (não ficas mais ilegal do que o que já estás B)).

Eu  uso VM-Ware player, é gratuito (embora exija registo para fazer o download), e muito porreiro, senão o Virtualbox também faz o truque.

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
fil79    5
fil79

Ou seja, o melhor é mesmo fazeres uma instalação de raíz. Tenta o truque que o acao te disse, a ver se funciona. Para usares o XP, experimenta o XP mode (acho que só está disponível da versão professional para cima, mas não tenho a certeza).

correcto, disponivel nas versões Professional, Enterprise, e Ultimate

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
thoga31    611
thoga31

Formatar de novo? Bem, que assim seja. :dontgetit:

Formatando directamente os discos a partir do Ubuntu vai meter o bottloader a "zeros", suponho?

Ou preciso de fazer um outro género de desinstalação?

O XP Mode para mim está ok - quando compro, compro o melhor, e o Ultimate é a minha onda. :D

Eu sei que isto aqui é de Windows, mas alguém me pode dar umas dicas rápidas de como refazer as partições do disco a partir do Ubuntu? É que pelo XP eu sei muito bem, mas pelo Ubuntu...

Ou, quando instalar de novo o 7, posso gerir logo lá as partições?

Se sim, querem-me dar umas dicas de como é o "sistema"? Aqueles ambientes de instalação do Windows de raíz nunca foram a minha onda, e eu não quero meter o 7 nem no Disco D (fica para outras coisas), nem num Disco C com uns míseros 72GB. :D

Obrigado, mais uma vez. Sou mesmo um chato, pah :D

Cumprimentos,

thoga31

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
Flinger    50
Flinger

O windows 7 é mais gráfico que o XP. Podes perfeitamente controlar lá as partições:

Ao arrancares, vais seguido os passos até te perguntar qual é o tipo de instalação que queres, Upgrade ou Custom. Escolhes custom, e logo a seguir ele mostra-te as Unidades que tens. A partir daí podes criar as partições (drive options) e escolher onde queres instalar o windows. Por defeito, ele vai-te criar uma partição de 100MB (caso não exista), presuponho que é onde ele coloca o boot.

Se vais ficar só com o 7, o melhor deve ser criares as partições a partir daqui, e não através da imagem de ubuntu.

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
thoga31    611
thoga31

Obrigado. :D

Entretanto não terei tempo para isso, possivelmente só lá para Fevereiro, já. Enquanto e não, a ausência do SP1 não me faz diferença.

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
nunopicado    1059
nunopicado

Pois é, metes-te em trabalhos... lol

As partições que fizeres para o 7 devem ser feitas pelo 7. Senão tás sujeito a problemas como tiveste da primeira vez. O 7 gosta pouco de outros galos na capoeira.

Independentemente disso, no Ubuntu tens de ir ao gparted (Gestor de Partições), normalmente dentro de Administração, ou algo assim. Lá dentro, o funcionamento é suficientemente intuitivo!

Se não me falha a memoria, o upgrade poderá ser instalado de raiz numa partição (formatada por ele), desde que qualquer outra partição ou disco tenham uma instalação de outro windows.

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
thoga31    611
thoga31

Eu instalei o Windows sem upgrade. Foi custom, e mandei meter na partição D, criada pelo XP que está na C. :D

Vou ver se consigo instalar o SP1 sem ter de reinstalar o Windows. Não me apetecia lá muito, já tenho isto ao meu gosto... :D

Mas se essa for a única solução que assim seja. Elimino de vez o XP, rearranjo as partições (de novo), e volto a meter tudo ao meu gosto. E instalo o XP Mode se conseguir, finalmente, encaixar o SP1... :D

Obrigado a todos

P.S. - uma sugestão de partições para 500GB? :D

  • Antes - C: 72GB; D: ~400GB
  • Agora - C: 72GB; D: ~200GB; G: ~200GB
  • Depois: ? :D

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
nunopicado    1059
nunopicado

Pois, convém mesmo que seja o 7 a format a partição que vai usar, até porque ele cria também uma partição reservada que usa (ou não) sabe-se lá para quê...  :D

Dos tamanhos, só tu poderás dizer com certeza do que precisas, mas se é para ficar só o 7 (sem mais nenhum SO), eu punha aí uns 100 + 400...

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
Flinger    50
Flinger

Quanto a tamanhos de partições, já não opino... No meu PC não acerto isso nem a tiro de caçadeira... Criei uma partição de 40GB só para o SO, todas as instalações de programas vão para outra partição. Resultado, o gajo conseguiu encher a partição na mesma, e agora nem espaço para o SP1 tenho... lá vou ter de formatar o PC outra vez :S

Por isso, se te posso dar um conselho, não poupes na partição do SO.

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
nunopicado    1059
nunopicado

Flinger: Podes usar um gestor de partições para redimensionar a partição de sistema, "comendo" um pouco na outra.

Não soa lá muito bem, pelo menos para mim, mas o que é certo é que já fiz isso uma mão-cheia de vezes "em desespero de causa", e nunca me deu problema, nem durante, nem depois.

Mas pelo sim pelo não, também não custa haver copias de segurança! :D

Salvo erro, o ultimo que usei foi este: http://www.partition-tool.com/easeus-partition-manager/help/resizing-and-moving-partition.htm

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
Flinger    50
Flinger

Gosto pouco de brincar com partições. Já lá vão uns anos, mas a última vez que tentei, com o partition magic, fiquei sem uma partição carregadinha de dados.

Mas de qualquer forma a partição a seguinte à do SO, é a das instalações. Se formatar o PC, vou ter de reeinstalar tudo e vou, por isso talvez valha a pena tentar o redimensionamento :D

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
nunopicado    1059
nunopicado

Sim, não perdes nada, porque a alternativa é fazer o mesmo que farás se algo falhar!  :cheesygrin:

Mas como disse, umas 4 ou 5 vezes que já fiz isso (também porque a alternativa não era animadora, e não fazer nada era ainda pior), não me deu problemas...

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!

Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.

Entrar Agora


×

Aviso Sobre Cookies

Ao usar este site você aceita a nossa Política de Privacidade