• Revista PROGRAMAR: Já está disponível a edição #53 da revista programar. Faz já o download aqui!

bensousa

Dúvida em excel (Condições se [IF])

9 mensagens neste tópico

Boa tarde.

Há uns tempos ja fiz o que pretendo mas como não tenho "pegado" no excel esqueci-me....

Tenho uma folha de cálculo com as cotações das questões de um teste ...

Numa das colunas está o somatório das questões. Pretendia o seguinte:

Quando determinado aluno tem (por exemplo) 55% num teste eu pretendia que em vez dos 55% aparecesse o nível (exemplo) 5 !!!

E se em vez de 5 aparecesse SATISFAZ' ?

Sei que existe a formula .... mas ja estou destreinado :-[

Obrigado :)

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

"Assim de repente", podes por exemplo usar if's encadeados

Tipo:  IF (Sum(A1...A1)<10)then "1"; if(10<sum(a1...a10)50) then "2" ...?

O que me "confunde" e nao esta a dar é o THEN

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Se o file que tens não tiver informações privadas/confidenciais envia ai que é para o abrir e tentar fazer isso 'no terreno'

(se tiver apaga ou qq coisa assim)

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Aqui vai

Pretendia na coluna das classificações não aparece a soma em percentagem mas sim o nível ... tipo se tiver 10% aparece 1... se tiver 555 aparece 3 e ...

Desde ja obrigado

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

=SE(Z5=0;"Zero";SE(Z5<50;"Fraco";SE(Z5<100;"mau";"m")))

É isto que precisas.

Ve lá se já dá para te orientares ;)

No fim escondes a coluna Z.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Eu lembro-me de fazer isso em TIC... penso que exista mesmo um menu para essa função.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

=SE(Z5=0;"Zero";SE(Z5<50;"Fraco";SE(Z5<100;"mau";"m")))

No fim escondes a coluna Z.

Está perfeito. Fiz uma alteração... substitui a célula Z5 pela soma das células das questões. Assim "evito" esconder a célula.

Obrigado

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Exacto! ;) Eu é que estou tão habituado a simplificar...(para mim é simplificar, mas muitas vezes até complico :) )

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!


Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.


Entrar Agora