• Revista PROGRAMAR: Já está disponível a edição #53 da revista programar. Faz já o download aqui!

magician

Problemas com alguns caracteres em linux :(

6 mensagens neste tópico

Boas pessoal tou a desemvolver uma aplicação em java que foi desemvolvida em win e tem interface grafica em SWT, até aqui tudo bem funciona em win perfeitamente mas agora ja que uso java aproveito os recursos do mesmo e queria que o programa funciona-se em linux e mac tambem, e ele realmente funciona pelo menos em linux pk mac nao tenho onde testar :D O problema é que no interface alguns caracteres aparecem maradados por exemplos oe acentos, ~,^, ',´,´ Ç, tudo o que seja caracteres fora de standart ficam com ? no lugar por exemplo 1 Não fica N?o o que se diga de passagem transforma o interface num verdadeiro LIXO :P niguem sabe como posso resolver isto ??

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Dependendo da distro de linux. Eu no Debian já tive problemas desse tipo, mas com o sistema de packages facilmente instalei um novo pacote de fonts e resolveu o prob.

Agora tudo depende da distro em que isso acontece, para poderes adicionar as fonts que estão em falha.  :P

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

acho que o problema é a codificação de caracteres que estás a usar. provavelmente é diferente em windows e em linux. é que existem vários padrões de caracteres em que os primeiros 128 caracteres são comuns, mas os restantes não.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

O problema não é das fontes isso tenho a certeza.

O mais provavel é ser da codificação. E como resolvo isso ?

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

O problema não é das fontes isso tenho a certeza.

O mais provavel é ser da codificação. E como resolvo isso ?

até agora o único sitio no qual consegui resolver o problema foi na consola do Mac OS X (tinha lá uma opção que permitia escolher a codificação).

provavelmente na consola do linux também deve haver.

no vim também tens a opção ":set encoding" para seleccionar a codificação de caracteres, mas não sei se isto resolve o problema.

a solução mais simples (e que eu tento utilizar) passa por não usar caracteres acentuados e ç nos programas...

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!


Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.


Entrar Agora