• Revista PROGRAMAR: Já está disponível a edição #53 da revista programar. Faz já o download aqui!

rjsma

[RESOLVIDO] problema com a textbox

8 mensagens neste tópico

boas

tenho uma form ligado a uma bd mysql  com varios campos para introduzir informacoes pessoais(nome,apelido,numero de telefone,etc)

quando executo a form vou preenchendo os campos mas chego ao campo para introduzir o nr de telefone depois nao me deixa seleccionar mais nenhum campo fica sempre seleccionado o campo do nr, de telefone

julgo que seja na bd que o campo esteja mal feito,ja tive a dar voltas e mais voltas e nao encontro o problema

na bd tenho assim

nr_telefone do tipo tinyint com o tamanho 9

cumps

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Não devia estar relacionado. Quero dizer, não era a base de dados que te travava a textbox, muito menos MySQL.

A menos que estejas a usar binds manhosos. Sabe-se lá o que se encontra na Internet hoje em dia...

De qualquer modo, não existem "tinyints" com 9 "digitos".

TINYINT tem um alcance de -128 até 127. Um número de telefone lança-se para a casa dos cem milhões.

Achas que vale a pena lidar com números tão grandes?

Um campo de telefone deveria ser alfanumérico e não numérico.

Lidar com 9 caracteres de texto é muito melhor do que lidar com números na casa dos milhões.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

ja alterei o tipo do campo e continua a bloquear na textbox

e agora tive a ver melhor e acontece a todas as textbox que tenho que inserir numeros

cumps

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Já actualizas-te a Dataset? Partindo do principio que estejas a usar databindings apartir do momento em que alteras alguma coisa na estrutura da bd tens de actualizar o Dataset, doutra forma mesmo que tenhas um tipo de campo na BD, no Dataset a informação continua a ser a mesma (TinyInt).

Cumprimentos

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

ja tinha actualizado a dataset varias vezes e nao funcionava contudo apaguei a dataset e fiz de novo agora ja esta a funcionar a mil maravilhas

obrigado a todos

:)

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Optimo. É mesmo isso que se quer, agora coloca o topico como Resolvido.

Cumprimentos

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!


Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.


Entrar Agora