• Revista PROGRAMAR: Já está disponível a edição #53 da revista programar. Faz já o download aqui!

mendes88

algoritmo: area do rectangulo duvida

6 mensagens neste tópico

boas

estou a começar a dar as primeiras noções de algoritmos

foi-me pedido um exercício que apesar de simples, gostaria de ir mais alem

exercício: fazer um algoritmo que calcule a área do rectângulo

algoritmo "area_rectangulo"
var
c,l,a:real
inicio
escreva ("indique o comprimento do rectangulo")
leia (c)
     se c<0 entao
     escreva ("Valor impossivel. indique outro valor")
     senao
     escreva ("indique a largura do rectangulo")
     leia (l)
     se l<0 entao
     Escreva ("valor impossivel. indique outro valor")
     senao
     a<- c*l
escreva ("A area é",a)
fimse
fimse

este foi o algoritmo que fiz.

a minha duvida consiste em saber se é possível fazer com que o programa depois de dar os erros de "valores impossiveis", volte a pedir o valor pretendido.

se da, gostava de saber que comando se utiliza e como o insiro ali no meio

muito obrigado :D

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Já aprendeste ciclos?

Basicamente terias que ter um que te fosse repetindo a inserção dos valores, até ter valores válidos.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Esses mesmo. A condição de paragem pode ser uma pergunta, em que o utilizador é confrontado com a possibilidade de calcular (introduz S, 1, ...) ou terminar a execução (N, -1, ...).

Se souberes bem a diferença entre o "para" e o "enquanto", a tua escolha do ciclo vai ser igual à do Baderous. Se tiveres dúvidas, colocas aqui. :confused:

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

boas

grande ajuda mesmo. com a função enquanto realmente consegui fazer aquilo que eu queria

deixo aqui o algoritmo final já todo direitinho :confused:

algoritmo "area_rectangulo"
var
c,l,a:real
u:caracter
inicio
Escreval ("Indique as unidades de medida.")
Leia (u)
Escreval ("Indique o comprimento do rectângulo.")
leia (c)
     enquanto c<0 faca
              escreval ("Valor inválido. Indique um novo valor: ")
              leia (c)
     fimenquanto
Escreval ("Indique a largura do rectângulo.")
Leia (l)
     enquanto l<0 faca
              escreval ("Valor inválido. Indique um novo valor: ")
              leia (l)
     fimenquanto
a <- c*l
escreval ("A área do rectângulo é ", a, u, "2.")
fimalgoritmo

neste já adicionei uma função para verificar as unidades de medida e assim completar a resposta do ultimo "escreva".

obrigado a todos

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!


Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.


Entrar Agora