• Revista PROGRAMAR: Já está disponível a edição #53 da revista programar. Faz já o download aqui!

migg

Erro ao executar Gestor de Actualizações...

12 mensagens neste tópico

Boa noite, o meu problema é quando executo o Gestor de Actualizações dá o seguinte erro:

Impossível inicializar a informação do pacote

Ocorreu um problema impossível de resolver ao inicializar a informação do pacote.

Por favor reporte este erro no pacote 'update-manager' e inclua a seguinte mensagem de erro:

'E:Encountered a section with no Package: header, E:Problem with MergeList /var/lib/apt/lists/archive.canonical.com_ubuntu_dists_jaunty_partner_binary-i386_Packages, E:As listas de pacotes ou o ficheiro de status não pôde ser analisado ou aberto.'

e quando abro o Gestor de Pacotes Synaptic

E: Encountered a section with no Package: header

E: Problem with MergeList /var/lib/apt/lists/archive.canonical.com_ubuntu_dists_jaunty_partner_binary-i386_Packages

E: A lista de pacotes ou o ficheiro de estado não puderam ser analisados ou abertos.

E: _cache->open() failed, please report.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Vai à consola e faz:

sudo aptitude update

E vê lá o que ele te diz.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/archive.canonical.com_ubuntu_dists_jaunty_partner_binary-i386_Packages
E: As listas de pacotes ou o ficheiro de estado não pode ser analisado ou aberto.
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/archive.canonical.com_ubuntu_dists_jaunty_partner_binary-i386_Packages
E: As listas de pacotes ou o ficheiro de estado não pode ser analisado ou aberto.
Atingiu http://archive.canonical.com jaunty Release.gpg
Ign http://archive.canonical.com jaunty/partner Translation-pt_PT               
Atingiu http://archive.ubuntu.com jaunty Release.gpg                            
Atingiu http://security.ubuntu.com jaunty-security Release.gpg                  
Ign http://security.ubuntu.com jaunty-security/main Translation-pt_PT           
Atingiu http://pt.archive.ubuntu.com jaunty Release.gpg                         
Ign http://pt.archive.ubuntu.com jaunty/main Translation-pt_PT                  
Atingiu http://archive.canonical.com jaunty Release                             
Atingiu http://archive.ubuntu.com jaunty Release                                
Ign http://security.ubuntu.com jaunty-security/restricted Translation-pt_PT     
Ign http://security.ubuntu.com jaunty-security/universe Translation-pt_PT
Ign http://security.ubuntu.com jaunty-security/multiverse Translation-pt_PT
Atingiu http://security.ubuntu.com jaunty-security Release                      
Ign http://pt.archive.ubuntu.com jaunty/restricted Translation-pt_PT            
Ign http://pt.archive.ubuntu.com jaunty/universe Translation-pt_PT              
Ign http://pt.archive.ubuntu.com jaunty/multiverse Translation-pt_PT            
Atingiu http://pt.archive.ubuntu.com jaunty-updates Release.gpg                 
Ign http://pt.archive.ubuntu.com jaunty-updates/main Translation-pt_PT          
Ign http://pt.archive.ubuntu.com jaunty-updates/restricted Translation-pt_PT    
Ign http://pt.archive.ubuntu.com jaunty-updates/universe Translation-pt_PT      
Ign http://pt.archive.ubuntu.com jaunty-updates/multiverse Translation-pt_PT    
Atingiu http://archive.canonical.com jaunty/partner Packages                    
Atingiu http://archive.ubuntu.com jaunty/main Sources                           
Atingiu http://security.ubuntu.com jaunty-security/main Packages                
Atingiu http://pt.archive.ubuntu.com jaunty Release          
Atingiu http://archive.ubuntu.com jaunty/restricted Sources                     
Atingiu http://security.ubuntu.com jaunty-security/restricted Packages          
Atingiu http://security.ubuntu.com jaunty-security/restricted Sources
Atingiu http://security.ubuntu.com jaunty-security/main Sources
Atingiu http://security.ubuntu.com jaunty-security/multiverse Sources
Atingiu http://pt.archive.ubuntu.com jaunty-updates Release  
Atingiu http://security.ubuntu.com jaunty-security/universe Sources             
Atingiu http://security.ubuntu.com jaunty-security/universe Packages
Atingiu http://security.ubuntu.com jaunty-security/multiverse Packages
Atingiu http://pt.archive.ubuntu.com jaunty/main Packages    
Atingiu http://pt.archive.ubuntu.com jaunty/restricted Packages
Atingiu http://pt.archive.ubuntu.com jaunty/restricted Sources
Atingiu http://pt.archive.ubuntu.com jaunty/main Sources
Atingiu http://pt.archive.ubuntu.com jaunty/multiverse Sources
Atingiu http://pt.archive.ubuntu.com jaunty/universe Sources
Atingiu http://pt.archive.ubuntu.com jaunty/universe Packages
Atingiu http://pt.archive.ubuntu.com jaunty/multiverse Packages
Atingiu http://pt.archive.ubuntu.com jaunty-updates/main Packages
Atingiu http://pt.archive.ubuntu.com jaunty-updates/restricted Packages
Atingiu http://pt.archive.ubuntu.com jaunty-updates/restricted Sources
Atingiu http://pt.archive.ubuntu.com jaunty-updates/main Sources
Atingiu http://pt.archive.ubuntu.com jaunty-updates/multiverse Sources
Atingiu http://pt.archive.ubuntu.com jaunty-updates/universe Sources
Atingiu http://pt.archive.ubuntu.com jaunty-updates/universe Packages
Atingiu http://pt.archive.ubuntu.com jaunty-updates/multiverse Packages
A ler as listas de pacotes... Erro !
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/archive.canonical.com_ubuntu_dists_jaunty_partner_binary-i386_Packages
E: As listas de pacotes ou o ficheiro de status não pôde ser analisado ou aberto.
E: Não foi possível reconstruir a cache de pacotes
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/archive.canonical.com_ubuntu_dists_jaunty_partner_binary-i386_Packages
E: As listas de pacotes ou o ficheiro de estado não pode ser analisado ou aberto.

E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/archive.canonical.com_ubuntu_dists_jaunty_partner_binary-i386_Packages
E: As listas de pacotes ou o ficheiro de estado não pode ser analisado ou aberto.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Cola aí a tua sources.list:

gedit /etc/apt/sources.list

Deves ter ou um repositório manhoso aí ou então isso ia a meio de um update e pifou. Quando é que isso começou a dar? Depois de algum update?

EDIT:

Já agora, resolver isso é até simples (Google):

sudo rm -vf /var/lib/apt/lists/ *

Depois se fizeres update já deve dar :)

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Não sei quando é que começou só reparei quando abri o Gestor de Actualizações para actualizar para a versão 9.10

# deb cdrom:[ubuntu 9.04 _Jaunty Jackalope_ - Release i386 (20090420.1)]/ jaunty main restricted

deb-src http://archive.ubuntu.com/ubuntu/ jaunty main restricted #Added by software-properties

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to

# newer versions of the distribution.

deb http://pt.archive.ubuntu.com/ubuntu/ jaunty main restricted

deb-src http://pt.archive.ubuntu.com/ubuntu/ jaunty restricted main multiverse universe #Added by software-properties

## Major bug fix updates produced after the final release of the

## distribution.

deb http://pt.archive.ubuntu.com/ubuntu/ jaunty-updates main restricted

deb-src http://pt.archive.ubuntu.com/ubuntu/ jaunty-updates restricted main multiverse universe #Added by software-properties

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu

## team. Also, please note that software in universe WILL NOT receive any

## review or updates from the Ubuntu security team.

deb http://pt.archive.ubuntu.com/ubuntu/ jaunty universe

deb http://pt.archive.ubuntu.com/ubuntu/ jaunty-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu

## team, and may not be under a free licence. Please satisfy yourself as to

## your rights to use the software. Also, please note that software in

## multiverse WILL NOT receive any review or updates from the Ubuntu

## security team.

deb http://pt.archive.ubuntu.com/ubuntu/ jaunty multiverse

deb http://pt.archive.ubuntu.com/ubuntu/ jaunty-updates multiverse

## Uncomment the following two lines to add software from the 'backports'

## repository.

## N.B. software from this repository may not have been tested as

## extensively as that contained in the main release, although it includes

## newer versions of some applications which may provide useful features.

## Also, please note that software in backports WILL NOT receive any review

## or updates from the Ubuntu security team.

# deb http://pt.archive.ubuntu.com/ubuntu/ jaunty-backports main restricted universe multiverse

# deb-src http://pt.archive.ubuntu.com/ubuntu/ jaunty-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's

## 'partner' repository.

## This software is not part of Ubuntu, but is offered by Canonical and the

## respective vendors as a service to Ubuntu users.

deb http://archive.canonical.com/ubuntu jaunty partner

# deb-src http://archive.canonical.com/ubuntu jaunty partner

deb http://security.ubuntu.com/ubuntu jaunty-security main restricted

deb-src http://security.ubuntu.com/ubuntu jaunty-security restricted main multiverse universe #Added by software-properties

deb http://security.ubuntu.com/ubuntu jaunty-security universe

deb http://security.ubuntu.com/ubuntu jaunty-security multiverse

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Não, eu estive a mexer no fontes de aplicações secalhar foi disso podes dizer as configurações normais sff

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

O erro continua o mesmo? Mesmo depois de apagares o conteúdo da /var/lib/apt/lists/

Estranho.. a tua sources.list, que é a lista das fontes, está normal. O problema não deve ser daí.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Faz isto então:

sudo rm /var/lib/apt/lists/*
sudo dpkg --clear-avail
sudo dpkg --configure -a
sudo aptitude install -f
sudo aptitude update

E depois diz se funciona.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Obrigado, já funciona.

Eu sou uma pessoa que gosta de entender como o sistema funciona, se fosse posivel podias dizer o que faz estes comandos.

sudo dpkg --clear-avail

sudo dpkg --configure -a

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Sinceramente, também não sei :) Mas do manual do dpkg ( man dpkg ):

      --clear-avail

              Erase the existing information about what packages are available.

      --configure package...|-a|--pending

              Reconfigure an unpacked package. If -a or --pending is given instead of package, all unpacked  but

              unconfigured packages are configured.

              Configuring consists of the following steps:

              1.  Unpack  the  conffiles,  and  at  the same time back up the old conffiles, so that they can be

              restored if something goes wrong.

              2. Run postinst script, if provided by the package.

Ajudou? :D

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!


Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.


Entrar Agora