• Revista PROGRAMAR: Já está disponível a edição #53 da revista programar. Faz já o download aqui!

Chamuanza

Breakpoint não funciona

15 mensagens neste tópico

Oi Pessoal

De um momento para o outro o Breakpoint deixoiu de funcionar, aparece um icon diferente, tentei seguir a instrução dada quando carrego no icon mas não resultou.

O que e que faço?

Já agora pergunto, como fazer para dar o topico como resolvido, havia um botão no forum mas não dou com ele

Obrigado

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

O ícone diferente não será um círculo vermelho, não preenchido, com um sinal de exclamação?

Isso normalmente acontece quando estás a trabalhar com referências externas e por alguma razão o código da referência muda, como acontece quando estás a trabalhar em dois projectos distintos, em soluções distintas e tentas fazer breakpoints no código da outra solução, depois de a teres alterado.

Se for o caso, basta fazeres um Build na outra solução e actualizares a referência.

Se não for o caso... explica melhor o âmbito.

Quanto ao "Topic Solved", com a subida de versão do SMF, essa funcionalidade deixou de estar disponível, por agora, esperamos :P

Acrescenta um [RESOLVIDO] no assunto, como alguns têm feito.

Parece-me ser "the next best thing".

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Penso que o problema estava na mudança da data do sistema que eu provoquei para testar uma condição, e que depois não repus,o que vai ao encontro da tua explicação

Obrigado pela atenção

Resolvido

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Boa tarde pessoal.

Este problema já me aconteceu várias vezes, e sem uma causa em comum, ou alguma razão aparente..

Fico danado quando isso acontece, não sei mesmo como resolver esse problema... Gostava mesmo de saber como resolver isto. 

Normalmente costumo fazer sempre varios backups e vou pego no meu ultimo backup e acrescento o que fiz de novo. Queria mesmo saber como resolver isto. Porque já me aconteceu como o Ribeiro disse, mas tambem já me conteceu sem ter mais nenhum projecto aberto, por isso é que acho muito estranho o problema ou o que o causa.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Pessoal

Acabou de me acontecer de novo! Mesmo agora.. E eu estava a trabalhar normalmente sem mais nenhum projecto aberto nem nada.

Alguem conhece alguma solução para isto?

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Mas que mensagem mostra?

Não explica porque não conseguiu bater na linha?

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Não diz nenhuma mensagem de erro, mas quando acontece o tal problema, ponho o rato em cima do breakpoint e ele diz algo semelhante a que, a solução está a ser lida de uma fonte diferente.. Mas no entanto nem se quer abri outro projecto.

Mas Ribeiro, sabes do que estou a falar ou nunca te aconteceu? 

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Sei exactamente do que estás a falar... mas nunca me aconteceu de uma forma "WTF?".

Aconteceu sempre com a situação que descrevi. :P

Fechar a IDE e fazer um "Build" ou "Rebuild" no projecto não resolve o problema?

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Infelizmente não.. No entanto, no break point diz para ir-mos a tools - > options - > Environment - > Restor file associations

Mas tambem não adianta de nada..

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Isto parece uma praga! Paragava para saber o que causa isto, tenho perdido horas por causa disto.

Deixo aqui a mensagem do breack point.

http://img41.imageshack.us/img41/9742/breackpoint.jpg

Mas encontrei uma solução quando isto acontece, eu copio todas as forms e substituo no backup mais recente e fica a dar..

Não sei que problema isto me possa vir a dar. Alguem sabe de alguma coisa?

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

As sugestões dadas na tooltip são daqueles remendos para a vista.

O problema vai persistir.

Tens aqui uma thread dos fóruns da msdn com uma série de soluções possíveis.

Numa delas, perguntam se estás a tentar fazer debug em modo Release.

Esta teria alguma lógica, uma vez que ambos os modos vão parar a localizações diferentes, e voltávamos a pegar no exemplo que dei.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Obrigado Ribeiro.. Aquela threat tem bastantes sugestões!

Quando me acontecer outra, esperimento e digo alguma coisa.

Obrigado ;)

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Pessoal

Aconteceu-me de novo o tal problema.. Segui uma das sugestões que tinha na thread que o Ribeiro disse para ver.

Dentro da pasta Bin do projecto, apaguei tudo o que estava lá dentro. Corri de novo e PUF! Funcionou às mil maravilhas.

Gostaria de saber mais opiniões para saber se resulta com mais alguém ou não.

Obrigado ;)

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Por vezes acontece no caso de estares com uma solução com vários projectos onde algum deles é uma dll's e estas a tentar correr em debug.. por exemplo com sistema de plugins..

Também poderá acontecer caso tenhas outras instância do VS a correr com ficheiros modificados.. isto poderá acontecer mesmo que não te apercebas... verifica se tens duas instâncias do VS a correr no gestor de tarefas..

Para prevenir eventuais bugs, tem em conta que tens o ultimo service pack instalado..

Apenas falo por minha experiência..

Compr.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Sobre o Service Pack penso que tenho o ultimo instalado, mas ver procurar a certificar me disso.

Quanto a 2 instâncias abertas em principio nao deve ser disso mas quando tornar a acontecer vou estar antento.

obrigado e comprimentos :)

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!


Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.


Entrar Agora