• Revista PROGRAMAR: Já está disponível a edição #53 da revista programar. Faz já o download aqui!

booser

Duvida na instalação do arch linux

39 mensagens neste tópico

Boas,

Eu tive durante uns tempos o OpenSuse Gnome instalado, o que me parecia um pouco pesado.

Bem, eu pesquisei sobre o Arch Liux, o que me aconselharam noutro tópico.

Eu fiz o download do ArchLinux KDE, li o Wiki e já li um tutorial  aqui no P@P, mas surgeme uma duvida na instalação.

Correme tudo bem até a instalação do Grub, não sei como instalalo e li num tutorial que podia desprezar e carregar logo no F2.

Quando reenicio as opções que me aparecem é para correr o Arch e um safefail (se não me engano).

Pois eu vi que fiz literalmente mer** , tive de instalar o OpenSuse de volta para poder aceder outra vez ao Windows.

Como  instalo o GRUB com o windows já instalado?, o que sei é que tenho de ter uma partição dedicada para o boot, e que esta partição tem que estra em 1º, mas eu tenho o sda1 para windows, sda3 para root, sda5 para swap, e o sda6 para /.

Depois disto, o que é que tenho de fazer para por o Arch a correr?

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Podes instalar o grub ja com o windows instalado, ele consegue "ver" o windows e acrescenta a entrada para o mesmo no menu. Caso contrario, da um pouquinho de trabalho, mas consegue-se fazer.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

boas, em relação ao GRUB já está resolvido.

Quando se configura o grub, aparece o tal texto e se andarmos para baixo está lá os titulos que o grub vai adicionar.

A resolução é simples, cada linha do windows tem um #, temos de tirar esse # de cada linha, so deixamos o da primeira linha, tal e qual como está no titulo do Linux.

Agora surge outro problema, já tenho tudo instalado, estou encalhado naquela parte a seguir a reniciar o pc.

Eu digito /etc/pacman.conf e ele diz "access denied" , ponho pacman -U , ele tb nao deixa.

Talvez se partisse logo para a interface do Arch fosse mais fácil instalar o que falta, como é que resolvo isto?

Cumprimentos

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

sim claro, isso é óbvio.

Alem de não ter outra hipótese, porque ele mal arranca faz os loads que tem a fazer e pede logo o utilizador e password.

Eu meto root e a pass, mas não me deixa instalar nada do pacman.

E vi um  comando para aceder logo à interface (julgo que seja "startx").

mas não deixa fazer nada.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

antes de mais, faz la este comando: #pacman -Syu

O comando que fizes-te (#pacman -U ) apenas te permite instalar pacotes que tenhas guardados na tua maquina, ora se executas o comando e nao tens o pacote para instalar, claro k ele nao te deixa fazer nada e da erro.

O comando para acederes a lista com os mirrors e: #nano /etc/pacman.conf

Se nao meteres o editor antes, nao fazes nada.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Um dia destes hei-de me dar ao trabalho de instalar o Arch outra vez.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Eu já tentei o

nano /etc/pacman.conf

, aparece o tal editor, e nos repositorios de "core", "extra" e "community" a unica coisa que aparece é

include= /etc/pacman.d/mirrorlist

.

tenho que adicionar os repositorios dentro do editor? quais é que aconselham?

Eu tentei carregar ctrl-X e escrever

include=/etc/pacman.d/current

e depois

pacman -Syu

, mas não deu.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Eu quando chegar a casa, coloco aqui o meu mirrorlist. Depois copias e colas no teu.

Depois de copiares o ficheiro anterior, fazes o comando: #pacman -Syu  . Ou seja, este comando permite-te fazer um refresh aos repo, e actualiza-te o sistema.

Ja agora, como quem nao quer a coisa, faz um ping ou um ifconfig a ver se tens rede.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

bem o meu mirrorlist comeca desta forma:

# Mirror used during installation

Server = ftp://cesium.di.uminho.pt/pub/archlinux/$repo/os/x86_64

(...)

das reticencias pra baixo e so servers comentados. Coloca esse mirror (adequado ao teu sistema, pois o meu e de 64bits) e tanta o pacman -Syu.

btw, o meu pacman.conf é este:

#

# /etc/pacman.conf

#

# See the pacman.conf(5) manpage for option and repository directives

#

# GENERAL OPTIONS

#

[options]

# The following paths are commented out with their default values listed.

# If you wish to use different paths, uncomment and update the paths.

#RootDir    = /

#DBPath      = /var/lib/pacman/

#CacheDir    = /var/cache/pacman/pkg/

#LogFile    = /var/log/pacman.log

HoldPkg    = pacman glibc

# If upgrades are available for these packages they will be asked for first

SyncFirst  = pacman

#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u

#XferCommand = /usr/bin/curl %u > %o

#CleanMethod = KeepInstalled

# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup

#IgnorePkg  =

#IgnoreGroup =

#NoUpgrade  =

#NoExtract  =

# Misc options (all disabled by default)

#NoPassiveFtp

#UseSyslog

#ShowSize

#UseDelta

#TotalDownload

#

# REPOSITORIES

#  - can be defined here or included from another file

#  - pacman will search repositories in the order defined here

#  - local/custom mirrors can be added here or in separate files

#  - repositories listed first will take precedence when packages

#    have identical names, regardless of version number

#  - URLs will have $repo replaced by the name of the current repo

#

# Repository entries are of the format:

#      [repo-name]

#      Server = ServerName

#      Include = IncludePath

#

# The header [repo-name] is crucial - it must be present and

# uncommented to enable the repo.

#

# Testing is disabled by default.  To enable, uncomment the following

# two lines.  You can add preferred servers immediately after the header,

# and they will be used before the default mirrors.

#[testing]

#Include = /etc/pacman.d/mirrorlist

[core]

# Add your preferred servers here, they will be used first

Include = /etc/pacman.d/mirrorlist

[extra]

# Add your preferred servers here, they will be used first

Include = /etc/pacman.d/mirrorlist

[community]

# Add your preferred servers here, they will be used first

Include = /etc/pacman.d/mirrorlist

# An example of a custom package repository.  See the pacman manpage for

# tips on creating your own repositories.

#[custom]

#Server = file:///home/custompkgs

[archlinuxfr]

Server = http://repo.archlinux.fr/x86_64

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

já fiz o que disseste, pus os servers no /etc/pacman.conf, gravo.

Quando faço o pacman -Syu, diz que que não tem acesso.

A minha arquitectura é i686, eu tentei os 2 servers que disseste, mas nao está a dar.

O  meu mirrorlist é bem grande, aparece os repositórios de todos os países.

E não deixa fazer ping

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Se nao deixa fazer ping é pk nao tens a placa de rede activada, logo o pacman -Syu precisa de net pra activar, LOGO (este logo escrito em grande é apenas pra concluir a frase e não no sentido de estar a falar num tom alto) nunca iras conseguir fazer o update/instalar pacotes via pacman.

se a arquitectura e 686, usando o meu file, s tens que alterar o x86_64 por i686 (se nao to em erro)

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

desculpa lá afinal parece que dá o ping, fiz "ping localhost" (não sei se é assim que deveria ter feito,mas foi a única que deu).

Em relação ao mirror é como estás a dizer, porque antes de tentar fui ver se dava na internet e deu, mas é como te disse, não acessa, e às vezes aparece que não consegue ler um ficheiro .tar.gz.

Fod****, quando disseram que o Arch era uma  boa distro para começar enganaram-me.  :) :wallbash:

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Arch é boa distro para começar para quem quer ficar saber alguma coisa de linux.... :)

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Arch é boa distro para começar para quem quer ficar saber alguma coisa de linux.... :)

O que ele disse.

Provavelmente não estás com permissão de root. Escreve whoami na consola e mete ai o que aparece.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

o ping ao localhost deu, pk fizes-te um ping a tua maquina :)

Para qualquer interaccao com o pacman (tirando a instalacao de pacotes guardados no teu pc) precisas de ter net, logo convem ter a placa de rede instalada.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Um bocado off-topic, só para informar que na próxima quarta-feira vai haver uma LIP no IST - Alameda, e vou dar um pequeno workshop de Introdução ao ArchLinux, onde entre outra coisas vou falar acerca da sua instalação e configuração.

Para quem estiver interessado: http://www.lip.neiist.ist.utl.pt/

Cumps

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Talvez seja a melhor opção para mim.

Como é que se vai ter à Alameda, é preciso pagar alguma coisa?

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Um bocado off-topic, só para informar que na próxima quarta-feira vai haver uma LIP no IST - Alameda, e vou dar um pequeno workshop de Introdução ao ArchLinux, onde entre outra coisas vou falar acerca da sua instalação e configuração.

Para quem estiver interessado: http://www.lip.neiist.ist.utl.pt/

Cumps

Porreiro, se precisares de ajuda apita, acho que ainda me lembro qualquer coisa de Arch. ^_^

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Estou com um problema nos repositórios, já activei na mirrorlist os portugueses e aparece-me os seguintes erros depois de fazer pacman -Syu:

sh: /usr/bin/curl: No such file or directory
error: failed to update core (error invoking external downloader)

Isto também para o extra e para community.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Edita o teu /etc/pacman.conf, e comenta as linhas que começam com XferCommand, no teu caso provavelmente será

XferCommand = /usr/bin/curl %u > %o

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Bem parece que embati na configuração do xorg, pelo que vi já não se usa o hwd. :wallbash: Neste momento estou a usar o virtual box para testar mas futuramente é para colocar num pc com gráfica intel.

Instalei o grupo xorg-video-drivers.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!


Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.


Entrar Agora