• Revista PROGRAMAR: Já está disponível a edição #53 da revista programar. Faz já o download aqui!

scorch

[Excel]Extrair mês de data

29 mensagens neste tópico

Ora aqui vai uma dúvida talvez básica, mas para a qual não encontro solução. O que eu queria fazer era o seguinte. Somar apenas os campos da coluna B que sejam positivos (já consegui) mas apenas se a correspondente linha na coluna E, que é uma data (12-02-2009 por exemplo) for do mês 02(Fevereiro).

A syntax actual que tenho é:

=SOMA.SE(B:B;">=0";B:B)

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Desculpa. :-[ Esqueci-me de mencionar. :wallbash: Tinha a impressão de que já tinha dito.

De qualquer maneira, isso não serve, porque o que eu quero fazer é uma condição.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Parece-me ser fácil,

Colocas a data por exemplo na célula A1.

Na celula B1 queres colocar/extrair o mês da data (A1).

Basta colocares na célula B1 a função: =Mes(A1)

Cumps

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Ok. Devo-me ter expressado mal. O que eu queria era que numa célula ele somasse os valores das células da coluna B se estas fossem positivas e se o correspondente campo da mesma linha na coluna E se o mês desta for igual a 02.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Fiz aqui num instante e penso que seja isto, a formula é:

=SE(SOMA(B2:B9)>=0;SE(MÊS(F7)=2;SOMA(B2:B9);"Condições inválidas");"Condições inválidas")

B2:B9 São as celulas que queres somar.

F7 É a célula da data.

Penso que seja isto :P

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Olá,

Podes usar a função SUMPRODUCT() que multiplica os valores correspondentes de um array e devolve a soma desses produtos

=SUMPRODUCT((B1:B50>0)*(MONTH(E1:E50)=2))

PS: Desculpa mas não uso as formulas em PT

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

pedrix21, tentei. Devia-me ter dado 6 e não me apareceu nada. Vou tentar a tua sugestão jpaulino.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

jpaulino, dá-me um erro. Adaptei para =SOMARPRODUTO((BB:BB>0)*(MONTH(EE:EE)=2)) mas dá-me #NOME.

Desculpem lá, mas não costumo trabalhar assim no Excel.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Agora não mostra nada, e devia mostrar 6€.

Ficou assim: =SOMARPRODUTO((BB:BB>0)*(MÊS(EE:EE)=2))

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

pedrix21, tentei. Devia-me ter dado 6 e não me apareceu nada. Vou tentar a tua sugestão jpaulino.

Tem que dar...talvez não estejas a meter os números que são para a soma dentro da coluna B.

Eu utilizei a coluna B e linhas do 2 ao 7.

Está testado :D

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Mas queres somar ou contar apenas ?

Se for somar podes fazer isto:

=SOMARPRODUTO((B1:B50>0)*(MÊS(E1:E50)=2)*(B1:B50))

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Se for somar podes fazer isto:

=SOMARPRODUTO((B1:B50>0)*(MÊS(E1:E50)=2)*(B1:B50))

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Tem que dar...talvez não estejas a meter os números que são para a soma dentro da coluna B.

Eu utilizei a coluna B e linhas do 2 ao 7.

Está testado :D

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

@pedrix21,

A formúla que colocaste não funciona. Eu ainda não experimentei, é verdade, mas tu estás a verificar se o total de uma coluna é >= 0 (SOMA(B2:B9)>=0) e depois verificas individualmente se a célula tem um mês 2 (MÊS(F7)=2), o que não está correcto.

Além disso, e ao fazeres dessa maneira, o que aconteceria se tivesses 200 linhas preenchidas ? Tinhas uma fórmula de um tamanho irreal.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

@pedrix21,

A formúla que colocaste não funciona. Eu ainda não experimentei, é verdade, mas tu estás a verificar se o total de uma coluna é >= 0 (SOMA(B2:B9)>=0) e depois verificas individualmente se a célula tem um mês 2 (MÊS(F7)=2), o que não está correcto.

Além disso, e ao fazeres dessa maneira, o que aconteceria se tivesses 200 linhas preenchidas ? Tinhas uma fórmula de um tamanho irreal.

O que ele disse:

"O que eu queria era que numa célula ele somasse os valores das células da coluna B se estas fossem positivas"

Logo terá que se fazer uma validação, penso eu...

Se tiver 200 linhas é só mudar o B7 para B200 :D

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

jpaulino, não soma nada. Dá zero. Queres que te mande o ficheiro por pm?

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

jpaulino, não soma nada. Dá zero. Queres que te mande o ficheiro por pm?

SIm, claro, porque funciona de certeza :D

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!


Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.


Entrar Agora