• Revista PROGRAMAR: Já está disponível a edição #53 da revista programar. Faz já o download aqui!

alphasil

Acentos no flash

7 mensagens neste tópico

Olá ppl

É assim, tenho um formulário em flash que depois envia os dados via php, o que acontece é que quando testo no meu pc, os acentos apararecem no próprio formulário, quando está online não poe os acentos no sítio,

Se fizer copiar e colar, dá tudo direito no flash, se tentar escrever não dá.

Pus embed e bitmap text no flash e tenho todos os latins e pontuação selcionados

se alguém quiser testar

http://www.gmcworks.com ( parte de contactos)

alguma ideia??

Cumprimentos

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

eu não sei que fonte estás a usar paras as caixas, mas vais ter k fazer um embed aos caracteres em cada caixa para que oas acentos funcionem e toma atenção se a fonte tem caracteres para acentos ou nao.

cumps

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Atenção que o embed de fontes torna o SWF mais pesado...  Então em formulários... tens de fazer o embed em cada uma das caixas de texto...

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Aqui funciona bem... ou eu percebi mal.

Eu escrevo seja o que for nas caixas e aparece todo o tipo de pontuação.

Quando vi o tópico, pensei logo no típico problema do loadvars resolvido com o useCodePage.

Por o sim e por o não, passa o useCodePage para true...

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

por exemplo no meu mac as vezes funciona meter acentos por exemplo no "é" e as vezes não, esperimenta meter isto éééééééé, aqui o que aparece é "ééeeeeeeéeeee" ;)

Aqui funciona bem... ou eu percebi mal.

Eu escrevo seja o que for nas caixas e aparece todo o tipo de pontuação.

Quando vi o tópico, pensei logo no típico problema do loadvars resolvido com o useCodePage.

Por o sim e por o não, passa o useCodePage para true...

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Pelo que dá para ver se não tiveres as fontes "embed" vão ser utilizadas as fontes do sistema do utilizador final....

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!


Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.


Entrar Agora