• Revista PROGRAMAR: Já está disponível a edição #53 da revista programar. Faz já o download aqui!

migg

Problema com hiperlink

10 mensagens neste tópico

Boas, a minha duvida é a seguinte eu ao passar com o rato por cima da hiperligação fica verde e sem estar com o mouse em cima da hiperligação está branco (como pretendia) mas eu ao clicar na hiperligação fica branco e quando passo por cima novamente já n fica verde...

Como faço para resolver o problema

<html>
<head>

<style type="text/css">

a:link {text-decoration: none; color: #FFFFFF}
a:hover {text-decoration: none; color: green}
a:visited {text-decoration: none; color: #FFFFFF}
a:active {text-decoration: none; color: #FFFFFF}

</style>
</head>

<body>


<a href="Documentos\regras.html"><div id="home">Home</a></div>

</body>
</html>

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Experimenta colocar a declaração do hover em último ligar, visto que a última declaração de valores para a mesma propriedade em CSS é a que tem efeito:

a:link {text-decoration: none; color: #FFFFFF}
a:visited {text-decoration: none; color: #FFFFFF}
a:active {text-decoration: none; color: #FFFFFF}
a:hover {text-decoration: none; color: green}

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Muito obrigado... Isto de aprender CSS pela net e livros tem as suas desvantagens

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Eu também aprendi CSS pela net, maioritariamente. Mas grande parte da experiência foi devido à parte prática, a mexer mesmo com CSS, editar templates, etc.

Isto aprendi com essa componente prática.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

migg, era melhor não colocares green. Acho que o IE7 dá problemas. Coloca antes #00FF21. :D

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

N há problema porque o site que eu estou a fazer vai ser para apenas 4 pessoas  e todos eles usam Firefox

Obrigado na mesma.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Olá,

Eu sou novo em css, embora esteja a apostar aprender o essencial para tirar partido na construção de websites.

Gostava de tirar uma dúvida, embora não tenha nada a ver com a deste tópico, é sobre hiperligações, pelo que penso não ser necessário um novo tópico.

A duvida é: eu coloquei uma hiperligação numa imagem (ex: logo para o index), mas desta forma aparece automaticamente uma borda roxa. O que preciso fazer para tirar?

Se possível pre-definir para não acontecer noutras imagens.

Obrigado

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Boas Melvins,

podias ter aberto outro tópico, ou pesquisado, não gasta mais por isso :thumbsup: De qualquer das formas, isso prende-se com o atributo border da imagem, que para evitar essa situação deve ser definido a 0.

<a href="enderecoDestino.html"><img src="teuLogo.jpg" alt="O meu logo" border="0" /></a>

ou usando CSS para todas as imagens:

a img {
  border: none;
}

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Obrigado!

Era mesmo isso, meter através de css pre-definido para todas as imagens.

P.S.: Espero que não haja problema ter feito neste tópico, simplesmente achei desnecessário estar a inaugurar um tópico só por causa deste pormenor, mas se for pela utilidade para outros posso reproduzir.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!


Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.


Entrar Agora