• Revista PROGRAMAR: Já está disponível a edição #53 da revista programar. Faz já o download aqui!

machi

Mau funcionamento da RAM

10 mensagens neste tópico

Boa tarde,

Encontro-me com um problema estranho em mãos.

Comprei o Pack 2x 2048Mb SODimm DDR2 Kingston 667 Mhz para o meu LG R500, para melhorar o desempenho do mesmo.

Retirei as duas memórias antigas, que eram de 1GB cada e inseri as novas, contudo quando é para arrancar com elas, o portátil não arranca. Nem sequer chega a apresentar o ecrã da BIOS.

Contudo, se inserir apenas num dos slot's a nova memória ou se juntar num slot antiga e noutro a nova já arranca normalmente.

O que poderá ser? Incompatibilidade penso que não seja, senão não daria para arrancar como referi anteriormente.

Terei que modificar alguma coisa?

Ficam aqui uns print's para que possa ajudar a esclarecer melhor o meu problema:

Memória antiga:

hynix.png

Memória nova:

kingstonf.png

Tipo de memória total permitida:

northbridge.png

Cumprimentos,

machi

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Para o update à BIOS só consigo encontrar no site do fabricante e a pagar.

Haverá mais alguma solução a juntar à que já foi referida?

Cumprimentos,

machi

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Experimenta só com 1 DIMM dos que compraste. Se efectivamente funcionarem os 2 individualmente, só fazendo o update da BIOS.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Experimenta só com 1 DIMM dos que compraste.

Contudo, se inserir apenas num dos slot's a nova memória ou se juntar num slot antiga e noutro a nova já arranca normalmente.

Update da bios a pagar? Acho isso muito estranho.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Update da bios a pagar? Acho isso muito estranho.

É a única solução que encontro, a pagar. :\

Onde poderei procurar pelo update? É que no software de actualização do portátil não me aparece nada para actualizar a BIOS. :P

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Boa tarde,

Já consegui fazer um update à BIOS e já consegui por a funcionar os dois módulos, no entanto só tenho cerca de 3GB de RAM disponíveis.

Penso que será devido a isto:

No entanto, o valor máximo de memória disponível em versões de 32 bits do Windows Vista, normalmente, é de 3,12 GB.

http://support.microsoft.com/kb/929605

Portanto, a não ser que mude para um versão de 64 bits do Vista é que poderei dar uso aos 4GB da RAM.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Yep, e repara que isso é mesmo uma limitação da arquitectura de 32bits, não é específico de um sistema operativo.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Algo desconhecido para mim até ao momento, estava convencido que poderia sem qualquer problema ter disponíveis os 4GB de RAM.

No entanto, problema e dúvidas esclarecidos.  :P

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Segundo sei, o espaço de endereçamento de cada aplicação é que é de pouco mais de 3GB, pois no espaço acima desse endereçamento estão mapeados os dispositivos de hardware.

No entanto, o Windows Vista utiliza a totalidade dos 4GB na distribuição da memória.

EDIT: não consigo encontrar nada que verifique o que acabei de dizer. Acho que foi algo que me disseram na cadeira de sistemas operativos.

EDIT2: Parece que estava errado: http://www.codinghorror.com/blog/archives/000811.html, particularmente esta imagem. Pelos vistos é um problema de arquitectura, que começa no desenho do chipset.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!


Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.


Entrar Agora