• Revista PROGRAMAR: Já está disponível a edição #53 da revista programar. Faz já o download aqui!

Sir Pereira

Joomla - Default Menu Item

14 mensagens neste tópico

Boas pessoal, é o seguinte, no meu site (www.rboaonda.pt.vu - se quiserem conferir), tenho o item "Notícias" definido como Default, e por isso ele abre-me a frame que tenho em cima novamente, isto é:

Abro o site. Pronto, tenho 2 frames, imaginando que o user vai às votações, e depois quer voltar para as notícias, vai-lhe surgir uma nova frame. Como evitar que isto acontece? O Joomla tem de ter mesmo um Default menu item?

Abraço ;)

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Em vez de teres o Notícias a apontar para o index.htm (/temp/), mete-o a apontar para o index.php (http://ivopereira.net/temp/index.php).

O problema é que ele está a apontar para o "index.php?option=com_content&view=frontpage", isto é, se eu mudar o endereço, ele vai dar-me um erro de módulo não encontrado...

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Não, ele está a apontar para ivopereira.net/temp/

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Não, ele está a apontar para ivopereira.net/temp/

Tens assim tanta certeza?

Semttulo-2.jpg

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Vê o template.

Bom, se calhar procurando aí até era capaz de resolver o problema, mas optei por mudar o tema, até porque aquele não se adequava bem às necessidades do que queria.

Já agora dá uma olhada no tópico que criei. É que o novo tema sobrepõe o tal link notícias deste tópico :) por isso em relação a isso deixo de ter problemas, mas não quero que o logótipo seja clicável.

Abraço

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

A única coisa que me aparece é uma caixa de login.

De qualquer maneira, porque é que não mudas o index.htm para frames.htm e metes o pt.vu a apontar para o frames.htm? É que desta maneira tinhas o problema resolvido, porque o que acontece é que tens 2 index.* e ele escolhe o .htm, que é o que tem as frames.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

A única coisa que me aparece é uma caixa de login.

De qualquer maneira, porque é que não mudas o index.htm para frames.htm e metes o pt.vu a apontar para o frames.htm? É que desta maneira tinhas o problema resolvido, porque o que acontece é que tens 2 index.* e ele escolhe o .htm, que é o que tem as frames.

Sim, porque já mudei o tema.

PS: Já resolvi o problema de retirar a hiperligação.

Ai pois é. Eu já tinha pensado isso, mas estava convencido que já tinha mudado, e por isso o problema não podia ser daí. Pronto distracção minha :)

Obrigado :)

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Sim, porque já mudei o tema.

PS: Já resolvi o problema de retirar a hiperligação.

Ai pois é. Eu já tinha pensado isso, mas estava convencido que já tinha mudado, e por isso o problema não podia ser daí. Pronto distracção minha :P

Obrigado :P

Ok, estou com o problema novamente.

Agora tenho domínio, e o que vai acontecer é que ao entrar em radioboaonda.com, ele vai escolher o index.htm, claro e é o que eu quero.

O problema é que ao carregar em Notícias ele vai escolher o mesmo index.htm, logo não posso mudar o index.htm para frames.htm porque se não depois ao entrar por radioboaonda.com ele vai reconhecer apenas o index.php e não coloca as frames...

Ajuda ? :D

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Boas pessoal ;)

parece que voltei ao mesmo.

Mas encontrei uma "suposta" solução.

http://forum.joomla.org/viewtopic.php?f=107&t=196509&sid=9a8d1330bab940bd5928b8f6a401484f&start=30

O problema é que, para que esta solução funcione o Joomla tem que estar instalado numa pasta fora do root, e eu tenho instalado no root (http://www.radioboaonda.com/), e gostaria de saber se por exemplo, dá para movimentar o Joomla todo para dentro de uma pasta (já com tudo instalado), sem ter problemas de links, links quebrados, imagens, etc.?

Abraço ;)

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Já resolvi a questão de mudar a pasta do Joomla, mas agora encontro-me com outro problema.

No tal fórum diz para, criarmos um ficheiro index.html

<html>
<head>
<title>Rádio Boa Onda</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
</head>
<frameset rows="60,*" frameborder="NO" border="0" framespacing="0" cols="*">
<frame src="player.php" name="topFrame" scrolling="NO" noresize >
<frame src="http://www.radioboaonda.com/portal/index.php" name="mainFrame">
</frameset>
<noframes>
<body bgcolor="#FFFFFF" text="#000000">
</body>
</noframes>
</html>

Pede para deixarmos o index.html e o ficheiro da frame (player.php) na pasta root, e fazer a ligação ao index.php do Joomla noutra pasta (/portal/).

O problema é que, após fazer tudo isto, e entrando pelo index.html acontece-me exactamente o mesmo. ;)

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!


Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.


Entrar Agora