• Revista PROGRAMAR: Já está disponível a edição #53 da revista programar. Faz já o download aqui!

Tesla

Apache + MySQL + PHP (Problema de ligação)

5 mensagens neste tópico

$hostname="localhost";
$login="root";
$pwd="r00t";
$db="mybook";

print "vou-me ligar à base de dados";
$ligacao=mysql_connect($hostname, $login, $pwd) or die("Connection failed!");
print "ligado ao motor da base de dados";
mysql_select_db($db, $ligacao);
print "base de dados escolhida";
mysql_close();
print "estou desligado";

O código acima deveria correr na totalidade, mas acontece que só vai até ao primeiro "print".

O que está mal? Tudo o que encontro na net como possível solução não acrescenta nada ao código acima.  :eek:

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Que instalação de PHP Mysql e apache fizeste? Foi algum pacote como o Xammp ou o WAMP Server?

Tens a certeza de ter alterado a password por defeito para "r00t"?

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Instalei mas de forma independente.

php5.2.8

apache 2.2x

mysql 5.0

defini uma password aquando da instalação do mysql e foi só!

Não sei porque razão a função mysql_connect(); não funciona! :S

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Instalei a última versão do wamp e já está tudo ok.

Só mais uma coisa, posso usar o GUI do Mysql com o WAMP?

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Só mais uma coisa, posso usar o GUI do Mysql com o WAMP?

Sim, o WAMP é apenas um pacote que instala tudo como deve ser, o resto é igual

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!


Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.


Entrar Agora