• Revista PROGRAMAR: Já está disponível a edição #53 da revista programar. Faz já o download aqui!

Rui Felgueiras

Publicar WebServices

9 mensagens neste tópico

Boa tarde pessoal.

Estou com algumas dificuldades em conseguir utilizar webservices.

O que acontece é o seguinte: construí um webservice em C# e com a ajuda o Visual Studio 2008. De seguida instalei na minha máquina o IIS para poder publicar o serviço. O que acontece é que eu não consigo publicar em condições o serviço, uma vez que eu tento consumir noutra aplicação de teste e nada..... ele não consegue detectar o serviço publicado.

Será que alguém me pode ajudar? Existem alguma configurações que devem ser tidas em conta?

Obrigado, e espero que tenha sido explicito  :(

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

mas se o abrires no browser funciona? o teste resulta?

é para ver se o problema vem do webservice ou da forma como o estás a consumir

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

O problema é que eu ao adicionar uma webreference consigo sem qq tipo de problema, mas depois ao compilar dá um Warning a dizer que não consegue encontrar a referencia e refere um Disco qq coisa  :wallbash:

Nao sei se ajudei mt. LOL

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Copia a mensagem de erro.

E mostra como estas a escrever o codigo para consumir o webservice

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

O warning que me da é o seguinte.

Warning 1 The custom tool 'MSDiscoCodeGenerator' failed.  Could not retrieve the current project.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Had the same problem.

Deleted the reference and added it under different name.

Now, i renamed it back to the original name and everything works fine now

tenta fazer isso

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

exprimenta um projecto novo pra ver se não é erro do próprio visual studio

cria um empty project novo, adiciona um webservice, mesmo o que ele cria por defeito chega

testas esse serviço no browser pra veres se está tudo bem

crias um projecto forms, adicionas a referencia e compilas pra ver se dá o mesmo erro

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Já experimentei de tudo pessoal.

O que estava agora a pensar era publicar num servidor externo, porque pode ser mesmo das configuraçoes do meu IIS.

Alguém sabe onde posso encontrar um alojamento gratuito onde possa publicar o meu WebService?

Obrigado.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!


Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.


Entrar Agora