• Revista PROGRAMAR: Já está disponível a edição #53 da revista programar. Faz já o download aqui!

David Pintassilgo

Problema com o monitor

25 mensagens neste tópico

Boas.

por algum problema que "desconheco" (a minha mulher mexeu no desktop :S ) o meu sistema (ubuntu) ficou com uma resolução de 600X400 ou coisa assim,.... tentei alterar aquilo para 1024 , 'ele' pediu-me para reeiniciar, e depois, no final do arranque (antes de pedir o login e pass) pifa.... o monitor desliga.

já consegui entrar para a consola. tudo ok. ao fazer:      startX... puff outra vez.

como corrijo o problema pela consola? Como altero as configuração?

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Qual é o tamanho do monitor? 15"?

Vê aí este log, vê se tem algum erro no final que possas pôr aí: /var/log/Xorg.0.log

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

ultima linha:

Could not init font path element /usr/share/fonts/X11/cyrillic, removig from 1$

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

yá... ando a ver se encontro como mudar a resolução pela consola..... pq foi ao mexer nisso que pifou. (a tentar meter de novo o 1024)

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Tens algum backup do xorg.conf? Tenta repor.

Fizeste algum update?

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

achei um backup disso, repuz.

agora ficou como estava quando cheguei a casa. esta tudo 'normal', mas com resolução de 640X480

agora devo de conseguir orientar isso (ou não :S)

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

:D

Não estou propriamente a conseguir resolver isto.

Alguma ideia de por onde comecar? Basicamente o problema é:

"Não consigo aumentar a resolução mais que640X480"

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

só uma ideia, está a usar o driver correcto, já reinstalaste os drivers do x para a tua placa ?

ou tenta com o driver vesa

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Alterei agora o driver para esse que me sugeriste. Realmente agora j]a d]a 800X600.

<(

Agora para j]a n\ao mexo mais, o monitor tb ]e de 15 pulgadas fica bom assim para j]a, *n\ao mexo mais nao va estragar tudo..

edit>

ups....

acho que com as mexidas que para aqui andei a fazer o teclado ficou um pouco marado...>S

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

vê se tens isto direito:

Option         "XkbLayout" "pt"

penso que pode ser disto.

agora não estou no slack não te posso dar muitas mais informações assim de cor ^^

já agora dantes tinhas alterado alguma coisa relativamente ao HorizSync e VertRefresh?

não podes colocar aqui o teu xorg.conf penso que seria útil :D

cumps,

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

screen > preferences > screenresolution

Mas já deves ter feito isso.

Provavelmente terás que editar o Xorg.conf manualmente. Faz um backup delel agora que está a funcionar caso isso piore.

Ora vê lá se tem lá as resoluções todas suportadas pelo teu monitor/placa.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

É pá... o teclado já rulla! :D

Eu para já dou o problema por resolvido, vou em breve fazer o upgrade para o 8.10 e depois ai então logo dou a volta a tudo.

Obrigado a todos.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Vê se na secção Display tens lá os modos de 1024x768. Em principio pode ser disso.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Mete aqui o xorg.conf

amanha ja faço isso, hoje nao chego a casa antes das 2H quase de certeza...:P

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

# xorg.conf (xorg X Window System server configuration file)

#

# This file was generated by failsafeDexconf, using

# values from the debconf database and some overrides to use vesa mode.

#

# You should use dexconf or another such tool for creating a "real" xorg.conf

# For example:

#  sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"

EndSection

Section "Module"

        Disable        "dbe"

        Disable        "dri"

        Disable        "glx"

        Disable        "vbe"

EndSection

Section "InputDevice"

Identifier "Generic Keyboard"

Driver "kbd"

Option "CoreKeyboard"

Option "XkbRules" "xorg"

Option "XkbModel" "pc105"

Option "XkbLayout" "us"

EndSection

Section "InputDevice"

Identifier "Configured Mouse"

Driver "mouse"

Option "CorePointer"

Option "Device" "/dev/input/mice"

Option "Protocol" "ImPS/2"

Option "ZAxisMapping" "4 5"

Option "Emulate3Buttons" "true"

EndSection

Section "Device"

Identifier "Failsafe Device"

Driver "vesa"

BusID "PCI:2:0:0"

EndSection

Section "Monitor"

Identifier "Failsafe Monitor"

Option "DPMS"

EndSection

Section "Screen"

Identifier "Default Screen"

Device "Failsafe Device"

Monitor "Failsafe Monitor"

DefaultDepth 16

SubSection "Display"

Depth 16

Modes  "800x600"

EndSubSection

EndSection

Section "ServerLayout"

Identifier "Default Layout"

Screen "Default Screen"

InputDevice "Generic Keyboard"

InputDevice "Configured Mouse"

EndSection

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Boas.

Tens isto:

Section "InputDevice"

  Identifier  "Generic Keyboard"

  Driver      "kbd"

  Option      "CoreKeyboard"

  Option      "XkbRules"  "xorg"

  Option      "XkbModel"  "pc105"

  Option      "XkbLayout"  "us"

EndSection

Nessa linha vermelha coloca em "pt". Mas antes de editares, faz um backup ao xorg.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Na section screen na subsection display tenta mudar

Modes  "800x600"

para

Modes  "1024x768"

ou para a resolução que pretendes

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Também podes tentar eliminar o config. As novas versões do X.org, supostamente deviam ser capazes de funcionar sem o ficheiro. ;)

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

M.offspring.R, o teclado já ficou a funcionar.

Sven, tentei e 'passou-se'. Tive de repor o backup.

Triton,.. simplesmente apagar o file, é?  :hmm:

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Adiciona é mais modos,

Por exemplo, o meu xorg.conf só tem isto na parde dos monitores e dos modos:

Section "Monitor"
Identifier	"Generic Monitor"
Option		"DPMS"
EndSection

Section "Screen"
Identifier	"Default Screen"
Device		"Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller"
Monitor		"Generic Monitor"
DefaultDepth	24
SubSection "Display"
	Modes		"2208x1766" "1368x1368" "1107x583" "1024x768" "944x708" "920x920" "800x600" "640x480" "560x420" "272x3072" "1x1"
EndSubSection
EndSection

se adicionares modos que o teu monitor aguente, supostamente devem ser possíveis de usar.

Já agora, se optares por apagar, não apagues, muda só de nome para o poderes repor facilmente.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

pedrotuga, modo 1x1?

Ehehhehe... para dizer a verdade, quando aqui afixei isto tambem fiquei assim a olhar e rir-me. É de facto cómico :) . Eu não editei isto manualmente, quando instalei o ubuntu neste computador ficou tudo a funcionar sem ser preciso nenhum ajuste.

Não sei por que motivo isso aí está, se é mesmo uma piada por parte dos amigos do xorg/xfree/whatever ou se úm bug, ou se é necessário para alguma situação. Mas lá que é engraçado, isso é.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!


Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.


Entrar Agora