• Revista PROGRAMAR: Já está disponível a edição #53 da revista programar. Faz já o download aqui!

ArturLaranja

Erro ao executar aplicação web no servidor

12 mensagens neste tópico

Boa tarde,

fiz um pequeno site que corre lindamente no meu portátil mas quando o corro no servidor o seguinte erro aparece:

Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately. 

Parser Error Message: Could not load type 'rlcvo._Default'.

Source Error: 

Line 1:  <%@ Page Language="C#" AutoEventWireup="true" CodeBehind="Default.aspx.cs" Inherits="rlcvo._Default" %>

Como resolvo isto?

Obrigado

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

esse nome de classe é muito estranho, foste tu que o escreveste assim ?

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

"rlcvo" é o nome do namespace e fui eu que lhe dei esse nome!

"_Default" é o nome da classe e foi dado assim automaticamente.

Alguém tem ideias do que isto possa ser?

Obrigado

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

experimenta mover ou copiar a directoria bin para a raiz

mover a /Aplicacção/bin para /bin

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

vitortomaz, era mesmo isso. Obrigado! :)

De qualquer forma agora pergunto: como faço para ter o .dll na directoria /Aplicação/bin e não apenas em bin?

Mas agora surgiu-me outro erro: estou-me a ligar a uma base de dados mdb cujo ficheiro está nessa mesma directoria bin mas ele diz que nao encontra...

A string de conexão é: OleDbConnection ligacao = new OleDbConnection("PROVIDER=Microsoft.Jet.OLEDB.4.0;Data Source=bd_visitas.mdb;");

Como resolvo isto?

Obrigado

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Fiz o publish da aplicação directamente para o meu servidor na Internet. O problema do path é que eu quando corro a aplicação no meu computador dou o path completo da base de dados, ou seja "c:\windows\users\...\bd_visitas.mbd"... Assim tudo corre bem! Acontece que no servidor nao posso dar esse path completo e assim dá o erro que mostrei no post anterior.

Ajuda precisa-se... :)

Obrigado

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

vitortomaz obrigado pela ajuda. Tenho o site a funcionar a 99%...

De qq das formas tenho um outro problema: quando algum utilizador escreve uma mensagem ocorre um erro relacionado com a base dados: "Operation must use an updateable query". O ficheiro da base de dados tem permissoes de escrita... Nao sei porque acontece isto...

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!


Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.


Entrar Agora