• Revista PROGRAMAR: Já está disponível a edição #53 da revista programar. Faz já o download aqui!

skin

Serious vulnerability in phpMyAdmin

1 mensagem neste tópico

All versions of phpMyAdmin, the popular MySQL administration tool, up to and including version 2.11.9.0 and the 3.0.0 release candidate 1, suffer from a code execution vulnerability. Versions 2.11.9.1 and 3.0.0-rc2 have been released with the vulnerability fixed. The phpMyAdmin developers describe the flaw as serious and recommend upgrading to the appropriate new version.

The advisory released by the phpMyAdmin developers stated the problem was that parameters of sort_by were not escaped and an attacker, if they were already logged in, could manipulate this to call the PHP exec function and run arbitrary code. The vulnerability was discovered by Norman Hippert in 3.0.0 RC1 initially, and checking showed that previous versions were also affected.

A partial workaround, for those unable to upgrade immediately, is to set disable_functions = exec in php.ini, but this change may have unwanted side effects, as it will block any PHP program from starting processes.

Update The vulnerability actually allows any PHP code to be run, so the above workaround is only effective against attacks where exec would be called. It is therefore recommended that users upgrade as soon as possible.

phpMyAdmin Code Execution Vulnerability

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!


Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.


Entrar Agora