• Revista PROGRAMAR: Já está disponível a edição #53 da revista programar. Faz já o download aqui!

Warrior

Wireless drivers

18 mensagens neste tópico

Comecei hoje a configurar o meu portátil com o ubuntu, mas o wireless está complicado..

Ele detecta como "Intel Corporation Unknown Device 4235".

PC: LG S510

Chipset: Mobile Intel PM45 Express

Wireless: Intel WifiLink 5300

Alguma ideia? Não encontro muita informação online sobre isto.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

É bem possível que não diga aqui nada que não saibas, mas caga para a lista do site do ndiswrapper.

Instala o ndisgtk, vai ao SITE DO FABRICANTE e saca o driver para winxp. Abre o ndisgtk e carrega o driver. Se não der das duas uma, ou tens a placa avariada ou sacaste o driver errado.

corre o comando lspci e faz copy paste da string da placa wireless no google. Isto para a eventualidade de estares enganado em relação ao hardware que tens.

Outra possibilidade que é compativel com inumeras placas wirelesse são os drivers madwifi, vale a pena tentar. Procura nos foruns ou no wiki do ubuntu. Algures está lá um pequeno tutorial para compilar o o madwifi mas introduzir correctamente a informação sobre a instalação na árvore de dependencias para poderes remove-lo com o teu gestor de pacotes caso desejes.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Tanto com os do winxp como com os do win vista ele reconhece a placa (pelo menos aparece um "yes").

O problema é que no lspci não muda nada, a placa continua a ser reconhecida como:

08:00.0 Network controller: Intel Corporation Unknown device 4235

Subsystem: Intel Corporation Unknown device 1001

Flags: bus master, fast devsel, latency 0, IRQ 10

Memory at c4000000 (64-bit, non-prefetchable)

Capabilities: <access denied>

Como é óbvio, no network manager ainda não aparecem opções de rede sem fios.

Talvez tente com os madwifi.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Não é suposto mudar nada, o lspci só faz uma listagem do identificador que está no hardware de cada dispositivo e que não podes mudar.

Agora o que eu acho que é muito esquisito é não aparecer nada no network manager quando te aparece um yes no ndiswrapper.

Isso é deveras bizarro.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Tanto o iwconfig como o ifconfig não detectam dispositivos wireless, apesar do "Yes"..

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Usei esse mesmo.

Fiz um apt-get ao ndisgtk visto ter net por cabo.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Não tens nenhum log de erro? Tens o ndiswrapper carregado? Se estiveres a usar não uses o GUI.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Eu li algures que estas placas vão ser suportadas automaticamente a partir do kernel 2.6.27 (acho eu), daí que estou à espera do meu cd do ubuntu chegar para instalar decentemente tudo. Instalei pelo Wubi e deu o mesmo problema que tu :P

EDIT: Ups...wrong kernel :P

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

O Foskasse tem um portátil igual ao do Warrior e já tem wireless no Arch.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Já tenho wireless no Ubuntu. Só hoje é que fiz o upgrade para 8.10, e já está tudo a funcionar. (não foi out-of-the-box mas quase, tive que copiar um file para /usr/firmware, mas pelo que li um clean install evitava isso..)

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Em Debian bastava instalar o pacote firmware-iwl4965-di. Ubuntu ou ainda não tem ou funciona de maneira diferente.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!


Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.


Entrar Agora