• Revista PROGRAMAR: Já está disponível a edição #53 da revista programar. Faz já o download aqui!

M.offspring.R

[Resolvido][Duvida] link quebrado?

9 mensagens neste tópico

Boas pessoal,

É a primeira mensagem aqui neste quadro e espero uma ajudinha em breve. Então o que se passa é o seguinte:

Tinha aqui um PC com uma página a correr fazendo uma ligação a uma base de dados Access. Este Pc foir formatado (criando-se antes o backup à pasta do site), instalei depois o IIS e coloquei a pasta no devido sitio.

O problema é aqui: Vou ao browser digito localhost/pasta, abre-me o default.asp mas depois não me abre mais nada... Tenho um botão para entrar mesmo no site/aplicação e não faz absolutamente nada... Dá-me um erro a dizer que a página não foi encontrada  ;) Já vi as ligações está tudo bem... Ando mesmo a stressar por causa disto.

Será alguma configuração da parte do IIS que me está a escapar? Eu tentei fazer com o EasyPHP (servidor Apache), mas o resultado foi o mesmo...

Alguém me dá aqui uma ajudinha?

Cump.

M.offspring.R

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

se escreveres à mão o endereço da página para a qual o botão supostamente reencaminha também não abre?

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Não abre.. Eu também já tinha testado... Acho muito estranho.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

não sei s ajuda, mas aqui vai:

verifica os caminhos no codigo da pagina, ja que ela veio de outro pc!

e verifica se tens no IIS istalado a versão ASP.NET que utilizas..

...

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

a pasta foi colocada no mesmo sitio.

Mas há uma coisa que não percebo. Se a pagina de entrada diz default.asp, e a de menu, menu.asp (a default tem um link para o menu), a 1ª dá e a 2ª não...

É a primeira vez que instalei o IIS, nado à toa com isto...

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Usas ASP ou ASP.NET ?

Se for ASP tens que activar no IIS o suporte para ASP. Não vem activo automaticamente.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Eu não pesco nada disto. Apenas peguei neste projecto (que já estava feito), fiz o backup e restaurei.

Agora pergunto, qual é a maneira (se é que há) para ver se é ASP ou ASP.NET?

Eu esta manha andei mexendo nas permissões da pasta e parece que ficou a funcionar... Mas lá no local é que tenho que ver.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

ASP.NET não é nada mais que a possibilidade de programar 'serverside' com a nova framework da microshit o .NET com geralmente a extensão .aspx.  :D

Um arquivo ASP normalmente contém tags HTML, tal como um arquivo HTML padrão. Um arquivo ASP também pode conter scripts do servidor, envoltos pelos delimitadores <% e %>.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Bem, parece que o site já ficou a funcionar.

Andei as voltas, revi permissões e ao que parece ficou a funcionar... Não me perguntem o que fiz, pois não sei.. Mexi em tanta coisa, alguma acabou por "ceder" :)

Obrigado pelas ajudas.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!


Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.


Entrar Agora