• Revista PROGRAMAR: Já está disponível a edição #53 da revista programar. Faz já o download aqui!

yschmitzz

Adicionando frameworks no projeto

11 mensagens neste tópico

Pow, o ruim do VB.NET eh que pra os outros pcs verem, tem q ter instalado o frameworsk 2.0 ou 3.5(nao sei exatamente qual o minimo) soube que eu posso adicionar as dlls do framworks junto ao projeto e mandar pra alguem q n tenha, que roda-ra tranquilamente, mas quais sao esses arquivos????

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

sim, vc nao intenmdeu minha pergunta xD

quero saber como que eu faço pra que o projeto rode na casa de quem nao tem o frame 3.5

me falaram uma vez que se compactar umas dlls do framework e colok juinto ao projto ele iria abri normal como se a pessoa tivese o frameworks 3.5

mas quero saber quais sao essas dlls especificas

pq qualse ninguem usa frame 3.5

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Entendi sim... Que eu saiba não podes fazer o que queres, incluis esse ficheiro de instalação com o teu programa e dás ordens para o instalrem antes de instalar a tua aplicação. Ou crias um setup para pa tua aplicação que inclua a instalação do framework e detecte se esta se encontra instalada, se não estiver, é só executares a instalação.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

sim, vc nao intenmdeu minha pergunta xD

quero saber como que eu faço pra que o projeto rode na casa de quem nao tem o frame 3.5

me falaram uma vez que se compactar umas dlls do framework e colok juinto ao projto ele iria abri normal como se a pessoa tivese o frameworks 3.5

mas quero saber quais sao essas dlls especificas

pq qualse ninguem usa frame 3.5

Ainda gostava de saber qual é o problema de instalares o .NET Framework 2.0, 3.0 ou 3.5! Existe algum motivo ?

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

o problema é a desenformação

muita gente nem sabe que isso existe

e outros tem net discadao

se fose pra um acessar um msn, um orkut

geral ia ter

mas pra programas....

por mim eu instalo sem problema, mas pena q nem todo mundo é asim

xD

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

o problema é a desenformação

muita gente nem sabe que isso existe

e outros tem net discadao

se fose pra um acessar um msn, um orkut

geral ia ter

mas pra programas....

por mim eu instalo sem problema, mas pena q nem todo mundo é asim

xD

tu é que tens de adaptar os teus programas ao teu público alvo. Se achas que eles por um ou por outro motivo não vão usar, então supera-te e tenta usar outra forma.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

hummm

intendi

vlw xD

mas eu sismei com isso

pq por exeplo

o Internet Explorer

nao precisa de frame 2.0 e tem um visual de xp

mozzila tambem

varios programinhas ae nao precisam de frameworks 2.0 e tem o visual do xp

e no vb eu so consigo deixar nesse visual usando o frame 2

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Teoricamente quando vais colocar a tua aplicação a funcionar necessitas de fazer uma instalação. Nessa instalação o .NET Framework respectivo é também instalado, o utilizador não precisa de ter essa preocupação. Provávelmente até vais ter necessidade de instalar o SQL, mySQL, CrystalReports Runtime File, etc.

Existem diversas tecnologias mas o .NET Framework tem muitas vantagens, como compilação JIT, optimização de memória, etc. Repara que existem diversos programas e até páginas que necessitam também que se instalale um "framework", como o java, macromédia, silverlight, etc.

O Vista por exemplo já traz o .NET Framework instalado e este framework faz parte da windows update, ou seja, acaba por ser instalado mesmo sem a tua aplicação.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

SIm, mas é instalado o 1.1 ou se nao me ingano o 1.0 o 2.0 nao é instalado assim q o windows é instalado

e mesmo assim aplicasoes do windows como o proprio Internet Explorer tem o visual o Framework 2.0 (quer dizer, tem o visual do Win Xp, que quando eu desabilito o frame, ou uso a versao anterior ao 2

.0 ele paga o visual do win 98)

é isso q eu queria intender

como eles conseguiram isso com o frame 1.1

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Vamos lá ver uma coisa. Conseguir consegues, não consegues é utilizar o .Net Framework 1.1 no Visual Studio 2008.

Arranja o VS2002 e eu explico-te como se faz.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!


Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.


Entrar Agora