Ir para o conteúdo
  • Revista PROGRAMAR: Já está disponível a edição #57 da revista programar. Faz já o download aqui!

tibi

a.link a.link:hover

Mensagens Recomendadas

tibi    1
tibi

Bons dias!

Alguem me pode dar uma sugestao aqui?

Eu tenho o codigo em baixo no ficheiro css que tenho no meu menu. Quando estou no site pela primeira vez funciona muito bem, mas quando entro nalgum grupo e volto a pagina inicial, ao fazer o over sobre o link, ja nao me faz o efeito que tenho em a.link_p:hover!!!! :thumbsup:

Porque sera!? ja tentei alterar alguma coisa no hover, mas o que tentei nao me da nenhuns resultados.

Esta alguma coisa mal, falta alguma coisa!?

a.link_p:link {

font-family:Geneva, Arial, Helvetica, sans-serif;

font-size:11px;

color:#3E4757;

text-decoration:none;

}

a.link_p:hover {

font-family:Geneva, Arial, Helvetica, sans-serif;

font-size:11px;

color:#808EA6;

text-decoration:underline;

}

a.link_p:visited {

font-family:Geneva, Arial, Helvetica, sans-serif;

font-size:11px;

color:#3E4757;

text-decoration:none;

}

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
softklin    12
softklin

Experimenta assim:

a.link_p:link, a:link_p:visited {
   font-family:Geneva, Arial, Helvetica, sans-serif;
   font-size:11px;
   color:#3E4757;
   text-decoration:none;
}

a.link_p:hover {
   font-family:Geneva, Arial, Helvetica, sans-serif;
   font-size:11px;
   color:#808EA6;
   text-decoration:underline;
}

Pode ser o facto da declaração vir depois do hover, uma vez que o CSS é interpretado de cima para baixo... Ou então pode nem ajudar, mas tenta  :thumbsup: É que aparentemente tens tudo certo no teu código... repetes é muito as declarações.

EDIT: faz CTRL+F5, e tenta o que fizeste anteriormente

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
tibi    1
tibi

experimentei da tua maneira. de facto o hover fica sempre a funcionar,quando entro e depois volto ao inicio, ele funciona :thumbsup:

mas não adquire o link normal do css :P

Mas obrigado pela dica! Não sabia isso da ordem do css e alterei o hover para ultimo e agora ficou a funcionar como pretendia  ;)

Obrigado

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
Sven    1
Sven

Eu punha só:

a.link_p {
   font-family:Geneva, Arial, Helvetica, sans-serif;
   font-size:11px;
   color:#3E4757;
   text-decoration:none;
}

a.link_p:hover {
  
   color:#808EA6;

}

assim primeiro defines como vai ser o link em todas as situações e alteras só o que é diferente para o hover

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!

Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.

Entrar Agora


×

Aviso Sobre Cookies

Ao usar este site você aceita a nossa Política de Privacidade