• Revista PROGRAMAR: Já está disponível a edição #53 da revista programar. Faz já o download aqui!

Byter

Duvida em php + Mysql

3 mensagens neste tópico

É o seguinte, tinha uma ligação a mysql de um formulario que enviava dados, numa tabela, apagei essa tabela, criei outra com os mesmos dados, mudei o nome da tabela no PHP, e ele Vai para o echo a dizer formulario enviado, e nao envia Nada!!!! Nem da erros! E parvo, deve ser a query que ta mal, mas so mudei o nome da tabela, e antes dava!

Vejam o codigo php:

<?
$dbhost = 'localhost';
$dbuser = 'lusopow_site';
$dbpass = 'PASSWORD'';
$dbname = 'lusopow_site';
$conn = mysql_connect($dbhost, $dbuser, $dbpass) or die                      ('Error connecting to mysql');

mysql_select_db($dbname);	
  $tabela = "alojamento";  
   $campos = "nome, senha, email, plano, ciclo, dominioja, namedom, domains, nomecomp, morada, localidade, observacoes, contribuinte, telefone, codpostal, data, registar, tipo, pagou, quantopagou";  
   $dados = "'$nome', '$senha', '$email', '$plano', '$ciclo', '$dominioja', '$namedom', '$domains', '$nomecomp', '$morada', '$localidade', '$observacoes', '$contribuinte', '$telefone', '$codpostal' , '$data', '$registar', '$alojarevenda', 'Não', '$quantia'";  
   $query = "INSERT INTO ".$tabela." (".$campos.") VALUES (".$dados.")";  
   $sql = mysql_query($query) or print(mysql_error()); 

?> 

E ele nao envia NADA!

Se me conseguírem ajudar, obrigado.

Cumprimentos.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites


$dbpass = 'PASSWORD'';
$dbname = 'lusopow_site';

Olha bem para o sintaxe... na variavel onde aplicas a password ($dbpass), usaste o sinal " ' " duas vezes, o que na seguinte abre outro "argumento", que se fecha quando defines a variavel "$dbname", é simples sintaxe, facilmente resolvido.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Esta resolvido, eram dados na base de dados mal verificados...

E isso da password, fui eu aqui no forum que me enganei ao mudar a password verdadeira para essa censurada, e pus um "'" a mais...

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!


Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.


Entrar Agora