• Revista PROGRAMAR: Já está disponível a edição #53 da revista programar. Faz já o download aqui!

filipemm

[Resolvido] Não consigo ligar net wireless no Fedora 8!

20 mensagens neste tópico

Boas!!

Instalei o Fedora 8 no portátil e tudo bem...

Acedi à net e fiz as minhas coisitas e tal..

Depois vieram as actualizações --> eu actualizei --> e puff.... FOI-SE A NET!!!  :mad:

Agora já nem consigo ver as redes disponíveis (coisa que antes conseguia [só não me conseguia ligar])...

Já pesquisei em tudo o que é foruns.. já tentei imensos comandos.. já editei as configurações todas.. enfim, já devo ter tentado de quase tudo..  :rant_01:

Espero que o melhor forum do pais e arredores me consiga ajudar  :P

PS. sou um bocado noob em Linux!!

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Qual a tua placa? podes meter aqui o seguinte  :

$ uname -r  && lspci && lsmod

Nas actualizas-te o kernel?

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Placa: Intel Corporation PRO/Wireless 3945ABG

uname -r --> 2.6.23.9-85.fc8 (suponho que seja a versão do kernel)

o lspci e o lsmod --> command not found

Sim, actualizei o kernel e agora no GRUB posso escolher entre 2.6.23.9-85.fc8 e 2.6.23.1-42.fc8...

Sugestões??

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Procura nos repositórios pelos módulos da tua placa para o kernel instalado (procura por iwl ). Se entrares com o kernel que tinhas antes tens net.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Procura nos repositórios pelos módulos da tua placa para o kernel instalado (procura por iwl ). Se entrares com o kernel que tinhas antes tens net.

Já fiz o download do driver para a placa... mas surgiu outro problema... a pen não é reconhecida!!

Também já tentei com o kernel de antes e não tenho net na mesma..

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Procura nos repositórios pelos módulos da tua placa para o kernel instalado (procura por iwl ). Se entrares com o kernel que tinhas antes tens net.

Já fiz o download do driver para a placa... mas surgiu outro problema... a pen não é reconhecida!!

Também já tentei com o kernel de antes e não tenho net na mesma..

Oppsss..

Já reconheceu a pen e já consegui instalar o driver.. mas não tenho net na mesma :S

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Qual é o resultado de #ifconfig ?

Caso o problema seja mesmo a placa que não tem o módulo bem instalado podes sempre seguir: http://intellinuxwireless.org/?p=iwlwifi&n=howto-iwlwifi

Já agora o resultado de $ lsmod

Problema resolvido.. já tenho net!! :D

Instalei isso do link et voi la!!

Mas já agora.. o # ifconfig e o $ lsmod deram command not found..

Obrigadíssimo pela ajuda :P

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Mas já agora.. o # ifconfig e o $ lsmod deram command not found..

Fizes-te como root?

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Mas já agora.. o # ifconfig e o $ lsmod deram command not found..

Fizes-te como root?

Penso que nas distribuições RH based não utilizam o ifconfig, devem utilizar outro comando.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Mas já agora.. o # ifconfig e o $ lsmod deram command not found..

Fizes-te como root?

Penso que nas distribuições RH based não utilizam o ifconfig, devem utilizar outro comando.

??

Isso não tem a ver com a distro em uso, o ifconfig funciona em todas as distribuições *NIX based. E já agora, uso fedora e faço uso do ifconfig.

Não sei que outro comando te referias... O que podes ter de fazer é executar sim o /sbin/ifconfig para o caso de não seres root.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Fiz o ifconfig como root porque tem o # atrás (isso é para ser como root, certo?)...

Mas como o lsmod tem o $ antes, fim como user normal...

Fiz alguma coisa mal??

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

deste algum espaço entre o # e o ifconfig?

Eu nem sequer pus o # porque assumi que com o # ele quisesse dizer para executar como su e com o $ para executar como user normal...

Não é isso?

PS. desculpem a minha "nobice" a linux :S

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Sim, é assim, sem # ou $. :P É muito estranho isso não fazer nada... Escreve if e clica no tab. Não te aparece ifconfig?

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Sim, é assim, sem # ou $. :P É muito estranho isso não fazer nada... Escreve if e clica no tab. Não te aparece ifconfig?

Não.. quando carrego no tab não aparece nada, mas se volto a carregar aparece ifnames..

É algum problema??

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Supostamente devias ter essa tool instalada... Que estranho...

Mas consigo "viver" bem sem essa tool.. ou nem por isso??

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Se não mexeres nas confs da rede, vives na boa. Mas de qualquer maneira, eu se fosse a ti, investigava isso...

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Se não mexeres nas confs da rede, vives na boa. Mas de qualquer maneira, eu se fosse a ti, investigava isso...

OK.. thanks..

Agora outra dúvida.. Eu pus aquele ícone para saber como estou de bateria, mas aquilo diz que estou a funcionar com energia da corrente, mesmo não estando o cabo ligado... Queria saber como pôr aquilo tipo Windows onde me mostra em que ponto da situação está a minha bateria..

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!


Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.


Entrar Agora