• Revista PROGRAMAR: Já está disponível a edição #53 da revista programar. Faz já o download aqui!

Hugu

co montar discos externos c liveCD's?

38 mensagens neste tópico

Boas!

Era o seguinte:

à dias tive uns probes no pc secretaria, de um momento para o outro deixou  de conseguir arrancar o windows

e nas tentativas de saber onde tava o probe, sakei o disco duro e metio-o numa caixa IDE-USB externa e no portatil (à segunda ou terceira tentativa (posicionar o jumper nos pinos certos) ), lá consegui aceder ao conteudo do disco duro.

Bem, probe n era do disco rigido..(fikei aliviado n ter perdido os dados!!)

dpx, co n havia modo de resolver o probe, o pc acabou de ter dir ao tecnico..

Lá, disseram k o probe era no disco rigido e numa das memorias ram (ram k eu comprei posteriormente e em outra loja de computadores...  :hmm:).

Ou seja, meteram um disco rigido novo e substituiram a tal memoria por uma equivalente.

Esta cena deixou-me lixado! :rant_01: porque probe do disco n era porque tinha conseguido aceder a ele...e da ram tb n era probe, porque tive-a mto tempo no pc e nunca achei ter probes qdo jogava joguinhos puxados.. e pelo o facto de o pc antes de ter ido pro tecnico, eu cheguei a meter, tirar e mudar as ordens das RAMs (2) nas 6 slots da motherboard.  :wallbash: (as rams avariam? nunca ouvi tal coisa! achei mto estranho  :hmm:)

Fiquei pior k tdo!  :mad: os gaijos n deram c o probe, e prontos, resolveram inventar e  meter coisa novas! O mal é k n tava em casa e foram os meus velhos k mandaram chamar o tecnico.. bem, tah feito, feito tah!!

E agora o meu pedido de ajuda era o seguinte:

tenho o disco rigido cmg, e voltei a tentar aceder a ele c a tal caixa externa IDE-USB aqui no portail e aparece-me akela msg de k o disco n tah formatado!! :D

k ******* fizeram-me eles ao disco?! :mad:

Entretanto, falaram-me pra n stressar e tentar aceder ao disco via linux...bem,  eu n tenho linux, mas tenho uns live-cd's (WifiSlax, BackTrack 2, Cassandra linux Mint e alguns cd's ubuntu k mandei vir)

Ja experimentei eles arrancando o linux em liveCD, mas nenhum deles detectou-me o usb externo (disco externo), apesar de o Mint ter-me detectado o disco do portatil, n me detectou a ligaçao externa :D

Co se faz pra montar o disco externo? ou k devo fazer?

Existe algum tutorial?

Obrigado

p.s.: terei esperança em recuperar o conteudo do disco??  ;)

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Entao ppl?!! :P

tantos users e niguem sabe co "montar" um disco externo apartir dum liveCD? ;(

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

tantos users e niguem sabe co "montar" um disco externo apartir dum liveCD? ;(

Não é com isto que vais arranjar uma resposta mais depressa.

No live cd do ubuntu, ele deve montar automáticamente. Se não, faz sudo fdisk -l para veres qual é o /dev/ da partição do disco a que queres aceder. Depois, mkdir /media/oSitioOndeQueroAcederAoDisco seguido por sudo mount -t (metes aqui ntfs ou vfat consoante a partição esteja formatada em ntfs ou em fat) /dev/queVisteNoFdisk /media/oSitioOndeQueroAcederAoDisco

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

tantos users e niguem sabe co "montar" um disco externo apartir dum liveCD? ;(

Não é com isto que vais arranjar uma resposta mais depressa.

mas parece ter resultado! ;D

vou entao tentar algo e dpx reporto!

Obrigado!

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

No live cd do ubuntu, ele deve montar automáticamente. Se não, faz sudo fdisk -l para veres qual é o /dev/ da partição do disco a que queres aceder. Depois, mkdir /media/oSitioOndeQueroAcederAoDisco seguido por sudo mount -t (metes aqui ntfs ou vfat consoante a partição esteja formatada em ntfs ou em fat) /dev/queVisteNoFdisk /media/oSitioOndeQueroAcederAoDisco

:P n tive sucesso... :P

Até pedi a um amigo k se safa bem c linux e n conseguimos montar o disco...detecta a caixa externa usb, mas sinal do disco propriamente dito nadinha! :P  ..é co no windows..detecta o dispositivo usb, mas qdo se clicka nele aparece uma msg a dizer k "o disco n está formatado e pergunta se quero formatar" :):(

N percebo co cheguei a aceder ao conteudo do disco qdo montei o disco na caixa externa antes de o pc ir pro técnico...mas depois de ter vindo o pc (c disco novo) do tecnico  nunca mais consegui montar o disco! :(

-Será k fiz merd*as c o jumper nas tentativas de ligar ele e acabou de deixar de dar de vez?

-Será k é por ser um disco Ultra ATA e a caixa externa so suportar IDE? (mas entao co consegui aceder uma das vezes?..)

será dos jumpers? pus o jumper em todas as posiçoes possiveis...será k preciso de usar mais jumpers?

Lembrei: Terá sido a placa circuito do disco k pifou? e se arranjasse uma placa circuito dum disco igual e trocá-la? é possivel trocar a placa circuito por outra igual ou equivalente?

eu vejo 4 parafusos...mas dará pra trocar ela sem interferir c o disco lá dentro? p.exe: se desaparafusar os 4 parafusos e sacar a placa circuito, a/as ligaçoes c o disco lá dentro n fica comprometido e a inutilizar o disco de vez?

Alguem me pode indicar o k terá avariado ou k outras avarias acontecem nos discos rigidos e co conseguir recuperar os dados do disco? :bye2:

Vou deixar os dados tecnicos:

Disco em causa: Barracuda 7200.7 120Gbytes , SEAGATE Ultra ATA (modelo: ST3120022A)

Caixa externa: 3.5" external case - usb 2.0 interface (cabo de ligaçao: 80 wire ribbon cable)

Obrigado

p.s.: e se alguem tiver um disco destes e puder vender uma placa circuito boa, k me contacte via pm

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Eu quando montei os meus 2 discos externos nessas caixas, coloquei-os em master... Já tentas-te? pode não ser a solução, mas não custa nada perder 5 minutos...

Penso se retirares esse circuito podes dizer "txau" ao disco...

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Oi,

Hugu, primeiro tem calma, e não formates o disco rigido, mesmo que o computador peça para fazer isso.

Aconselhava-te a ligar o Disco externamente na caixa como já fizeste, ires á  pela linha de comandos do DOS do teu portatil, e utilizar o CHKDSK para tentar recuperar o disco, ou utilizar o RECOVER para tentar recuperar os dados do Disco :P

Se a situação do Disco já está com circuitos estragados, tens que ter muito cuidado onde meixes e não te aventurares a trocar circuitos, senão os dados estragam-se definitivamente. Opta por testar este comandos que te indiquei primeiro.

Cumps :P

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Era só para lembrar que isto não é um chat, por isso é capaz de ser boa ideia escrever como deve ser.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
autor:M.offspring.R

Eu quando montei os meus 2 discos externos nessas caixas, coloquei-os em master... Já tentas-te? pode não ser a solução, mas não custa nada perder 5 minutos...

Claro!! sou burro mas nem tanto! :D

Até nem tive k mexer no jumper porque co o disco estava em master no pc secretaria...o jumper ja estava na configuraçao "master"!..mas co n consegui, tentei de tudo..mexer no jumper, usar diferentes SO, ligar o usb às varias portas usb, cruzar os dedos qdo ligava o power e até rezar 20 avé marias! :).. mas nunca tive sucesso :D

...e se for contar todo o tempo k perdi nestas tentativas, tvz diria k foram 5minutos X (uma porrada de vezes!!)

A caixa sei k n tem probes porque tenho outro disco montado na caixa (mas o disco é um IDE e n tem OS, serve mm só pra backup de dados)...agora o disco k me dá problemas é um Ultra ATA k tinha o Windows XP instalado e dados à mistura (sem partiçoes  :confused:)..por isso pergunto se será por ser um Ultra ATA a caixa "dár-se  mal" com estes discos e entao o problema em aceder ao disco? precisarei de drivers?..

autor:M.offspring.R

Penso se retirares esse circuito podes dizer "txau" ao disco...

:) :) :D entao co ha empresas k dizem fazer recuperaçao de dados apartir de discos "avariados"?  :dontgetit: co dão a volta à situaçao?

autor:jack

Hugu, primeiro tem calma, e não formates o disco rigido, mesmo que o computador peça para fazer isso.

Claro!...das mil e uma vezes k me apareceu essa msg, eu nunca aceitei a formataçao! O probe n é o disco dar o badagaio...até porque discos estao cada vez mais baratos...o probe é eu n kerer perder os dados k estao no disco!..  :bye2:

autor:jack

Se a situação do Disco já está com circuitos estragados, tens que ter muito cuidado onde meixes e não te aventurares a trocar circuitos, senão os dados estragam-se definitivamente. Opta por testar este comandos que te indiquei primeiro.

Tb n aconselha  troca da placa circuito, n é?  :D

eu n quero acreditar k a placa circuito tenha "queimado", porque o motor do disco rigido arranca sem barulhos estranhos..

Vou-me lá entao experimentar a via DOS! Mas... caro jack: co uso esses comandos CHKDSK e o RECOVER?  :dontgetit:

Obrigado a ajuda!..

...mas só vos pago uma bejeca qdo conseguir aceder aos dados do disco! :ipool:

p.s.:e porque é que o botao "citar" n está a funcionar??! oh senhores programadores...é um bocado vergonhoso, n? :P

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

p.s.:e porque é que o botao "citar" n está a funcionar??! oh senhores programadores...é um bocado vergonhoso, n? :confused:

Tens uma secção do fórum para dizer isso.
0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Tens uma secção do fórum para dizer isso.

Ainda n estou familiarizado c o forum e ainda desconheço a sua "arvore"...e só foi um reparo do momento!.. :confused:

e alguma ajuda, nada? ou agora fikei de castigo? :D

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Vou-me lá entao experimentar a via DOS! Mas... caro jack: co uso esses comandos CHKDSK e o RECOVER?  :dontgetit:

Hugu, para usares o CHKDSK fazes assim :

  -  Abres a linha de comandos

 

  -  Depois vais para a raiz (letra do disco que corresponde ao disco que queres recuperar) ( por exemplo - > d:)

-  Depois Digitas  -> CHKDSK - f, e depois esperas que termine a recuperação, se conseguires recuperar tentar guardar os dados para outro suporte para não correres novamento riscos.

Depois qualquer coisa, se deu ou não :D

Cumps :confused:

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Já tentaste algum programa de recuperação de dados? Não sei o que fizeste ao disco, mas soa-me que os ficheiros ainda lá estão, e o SO é que não os consegue interpretar.

Experimenta um destes

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Caro jack:

no meu caso é o directorio E:

discoenformatadoyw9.jpg

mas abri a linha de comandos e n consigo "montar" o directorio E:  :bored:

...é fazer \>cd e: , right? ...experimentei tb \>chkdsk e: e apareceu esta msg..

chkdskdiscoerq5.jpg

o k ker dizer RAW?

Já tentaste algum programa de recuperação de dados? Não sei o que fizeste ao disco, mas soa-me que os ficheiros ainda lá estão, e o SO é que não os consegue interpretar.

Experimenta um destes

N... experimentei as "ferramentas do sistema"...mas o desfrag nem seker detecta o disco..

Eu tb achava k o SO n detectava o disco e por isso é k n conseguia aceder a ele...mas dpx experimentei c Linux , live-cds ubuntu e outros e n tive sucesso..

O probe é mm aceder ao disco... :wallbash:

Dos programas, aconcelhas-me algum? TestDisk?vou experimentar este...

Voltando à placa circuito, e montar uma em paralelo? é mto MacGyver? ...mas já estou por tudo!  :mad:

Obrigado..

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Qualquer SO que não detecte o formato correcto dos dados não te vai dar acesso ao mesmo, caso contrário um utilizador inexperiente poderia causar estragos no sistema de ficheiros. Só programas especializados em procura de ficheiros perdidos é que possibilitam isso, dado serem especificamente criados para isso.

Um sistema de ficheiros RAW significa que o disco não está formatado. Ou por outra, significa que não foram encontradas as estruturas esperadas e o conteúdo não é encontrado.

Quanto aos programas, eu costumo utilizar o WinHex, mas não é grátis.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Tenta fazer mount -t auto /dev/sda1 /mount/disco

Troca o /dev/sda1 e /mount/disco pelos valores apropriados.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Não sei o que fizeste ao disco, mas soa-me que os ficheiros ainda lá estão, e o SO é que não os consegue interpretar.

O disco era o disco principal do pc de secretaria de casa dos meus pais e o pc um dia deixou de arrancar.. ja era habito o gaijo do nada reiniciar e das vezes k se ligava para o gaijo entrar era preciso fazer alguns resets...

O disco tava c windows xp e sem repartiçoes..ou seja..os dados andavam todos na mm secçao do sistema..

Antes de se chamar o tecnico, sakei o disco fora e montei numa caixa usb e fikei aliviado por o problema na ter sido no disco e k n iria perder os dados e k tvz fosse probes c o SO... O tecnico levou o pc e trouxe-o c uma memoria substituida (tinha dua memorias, uma de origem e outra k comprara dpx na concorrencia (a k foi substiutida)) e c um disco novo. Estranhei e tentei voltar a montar o disco na caixa externa usb e nada desde entao!...

Eu agora so posso experimentar aceder a ele montando na caixa externa usb, porque estou só c portatil, por isso gostava de saber co é k um disco rigido "avaria" ou deixa de ficar acessivel?...

Qualquer SO que não detecte o formato correcto dos dados não te vai dar acesso ao mesmo, caso contrário um utilizador inexperiente poderia causar estragos no sistema de ficheiros. Só programas especializados em procura de ficheiros perdidos é que possibilitam isso, dado serem especificamente criados para isso.

Um sistema de ficheiros RAW significa que o disco não está formatado. Ou por outra, significa que não foram encontradas as estruturas esperadas e o conteúdo não é encontrado.

Quanto aos programas, eu costumo utilizar o WinHex, mas não é grátis.

TheDark: ja tenho o WinHex...co é k se usa?

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Espera lá, mas mandaste o disco com o computador para arranjar? E se sim, tens a certeza que eles não apagaram o conteúdo?

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Espera lá, mas mandaste o disco com o computador para arranjar? E se sim, tens a certeza que eles não apagaram o conteúdo?

N estava em casa, estudo fora...os meus pais é k se lembraram de chamar o tecnico  de repente..

Pois...levaram o pc c o disco la dentro... eu acho k eles n apagaram nada, pk n foi dado autorizaçao.. mas n sei dizer, foram os meus pais k trataram da coisa..

mas tb kual era a deles subst o disco e mandarem um disco apagado?.. 

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Podem tê-lo formatado na tentativa de o pôr a funcionar. Podes ter tido sorte... mas...

De qualquer forma, tens o WinHex registado como Specialist (ou melhor)? Se tens, abres o programa, vais ao menu Tools -> Open Disk, e escolhes o teu disco na árvore sob Physical Disk.

Depois de aberto, vais novamente ao menu Tools -> Disk Tools -> Scan For Lost Partitions. No final ele deve dizer quantas partições encontrou. Se tiver encontrado alguma, pode ser que tenhas sorte. Se não encontrar nenhuma... então provavelmente estás com azar.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Estava a ter probes em registar o WinHex mas ja consegui...sim está em SPECIALIST e a versao é o Winhex 14.7 SR-1

vou tentar entao e ja digo kk coisa

edit:

hum..qdo fiz scan for lost partitions, apareceu uma janela a perguntar se "limite the search.." digo sim, n?

re-edit:

bem..acabei por dizer n e o programa parece ter crashado (porque a janela de estado deixou de mostrar a % de progresso)...mas o led da caixa mostra actividade e até agora mostra 1 partiçao.. agora vou ter k esperar k acabe o progresso right?

120Gigas qto tempo vai levar?..

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

É normal parecer que brekou. Mas tem paciência. 120GB deve levar um tempinho bom...

E fizeste bem em dizer não!

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

É normal parecer que brekou. Mas tem paciência. 120GB deve levar um tempinho bom...

E fizeste bem em dizer não!

fogo!..tive de deixar o portatil ligado all night para o processo concluir!..desconfio k foram preciso 6horas! :shocking:

...a chatice é k o programa crashou mm!

As unicas janelas activas eram a "Switched to hexadecimal offset presentation..." e uma janelinha "8bits, 16 bits e 32bits" e o programa propriamente dito "n se mostra"... mas nas miniaturas qdo faço alt+tab  consigo ver um janela k diz: "31 more partitcion(s) found to get it of bogus partitions, hide them and remove them from the volume snapshot. OK"

e agora? tenho de repetir o processo para continuar ou n importa e reinicio o programa?

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

É possível que ele tenha guardado uma snapshot do trabalho concluído. Só saberás experimentando.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Bem, o diabo do WinHex deu o berro definitivamente! ja reiniciei o pc varias vezes, e qdo cliko no executavel ele aparece na barra de tarefas, mas nada do interface do programa... porra k azar!

So estou a ver uma alternativa, desinstalar e voltar a instalar o programa...mas antes, onde e co posso salvarguardar o ficheiro relatorio ou o tal snapshot k resultou da operaçao k fiz? é k n estou pra voltar a repetir a operaçao! ;) 

6 horas?!!!  :shocking:

edit:

TheDark: tenho o programa de volta e a funcionar e agora? tenho de repetir akele processo?  :down:

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!


Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.


Entrar Agora