• Revista PROGRAMAR: Já está disponível a edição #53 da revista programar. Faz já o download aqui!

aluminium

Huawei e220 no Ubuntu 7.10 (Problema de DNS?)

8 mensagens neste tópico

A coisa está preta para estes lados. Hoje o modem Huawei E220 começou a ser reconhecido como um "usb-storage" e não como deveria e como está no "/etc/modules.conf", "usbserial".

Faço todos os passos como se da primeira configuração se tratasse, mas não funciona, ou seja, conecta, mas a ligação não funciona correctamente. Depois de ver o texto que aquilo mostra, reparei que os DNS estão mal. Penso que seja esse um dos problemas.

Aqui fica o texto para entenderem melhor:

sequeira@laptop:~$ pon.wvdial huawei_e220
sequeira@laptop:~$ WvDial<*1>: WvDial: Internet dialer version 1.56
WvModem<*1>: Cannot get information for serial port.
WvDial<*1>: Initializing modem.
WvDial<*1>: Sending: ATZ
WvDial Modem<*1>: ATZ
WvDial Modem<*1>: OK
WvDial<*1>: Sending: ATZ
WvDial Modem<*1>: ATZ
WvDial Modem<*1>: OK
WvDial<*1>: Sending: ATE0V1&D2&C1S0=0+IFC=2,2
WvDial Modem<*1>: ATE0V1&D2&C1S0=0+IFC=2,2
WvDial Modem<*1>: OK
WvDial<*1>: Modem initialized.
WvDial<*1>: Sending: ATDT*99***1#
WvDial<*1>: Waiting for carrier.
WvDial Modem<*1>: CONNECT
WvDial<*1>: Carrier detected.  Starting PPP immediately.
WvDial<Notice>: Starting pppd at Thu Jan  3 19:07:46 2008
WvDial<Notice>: Pid of pppd: 7606
WvDial<*1>: pppd: H���0�[06][08]��[06][08][01]
WvDial<*1>: Using interface ppp0
WvDial<*1>: pppd: H���0�[06][08]��[06][08][01]
WvDial<*1>: pppd: H���0�[06][08]��[06][08][01]
WvDial<*1>: pppd: H���0�[06][08]��[06][08][01]
WvDial<*1>: pppd: H���0�[06][08]��[06][08][01]
WvDial<*1>: pppd: H���0�[06][08]��[06][08][01]
WvDial<*1>: pppd: H���0�[06][08]��[06][08][01]
WvDial<*1>: pppd: H���0�[06][08]��[06][08][01]
WvDial<*1>: pppd: H���0�[06][08]��[06][08][01]
WvDial<*1>: pppd: H���0�[06][08]��[06][08][01]
WvDial<*1>: pppd: H���0�[06][08]��[06][08][01]
WvDial<*1>: pppd: H���0�[06][08]��[06][08][01]
WvDial<*1>: Authentication (CHAP) started
WvDial<*1>: pppd: H���0�[06][08]��[06][08][01]
WvDial<*1>: pppd: H���0�[06][08]��[06][08][01]
WvDial<*1>: pppd: H���0�[06][08]��[06][08][01]
WvDial<*1>: pppd: H���0�[06][08]��[06][08][01]
WvDial<*1>: Authentication (CHAP) successful
WvDial<*1>: pppd: H���0�[06][08]��[06][08][01]
WvDial<*1>: pppd: H���0�[06][08]��[06][08][01]
WvDial<*1>: pppd: H���0�[06][08]��[06][08][01]
WvDial<*1>: pppd: H���0�[06][08]��[06][08][01]
WvDial<*1>: pppd: H���0�[06][08]��[06][08][01]
WvDial<*1>: pppd: H���0�[06][08]��[06][08][01]
WvDial<*1>: pppd: H���0�[06][08]��[06][08][01]
WvDial<*1>: pppd: H���0�[06][08]��[06][08][01]
WvDial<*1>: pppd: H���0�[06][08]��[06][08][01]
WvDial<*1>: pppd: H���0�[06][08]��[06][08][01]
WvDial<*1>: pppd: H���0�[06][08]��[06][08][01]
WvDial<*1>: pppd: H���0�[06][08]��[06][08][01]
WvDial<*1>: pppd: H���0�[06][08]��[06][08][01]
WvDial<*1>: pppd: H���0�[06][08]��[06][08][01]
WvDial<*1>: pppd: H���0�[06][08]��[06][08][01]
WvDial<*1>: pppd: H���0�[06][08]��[06][08][01]
WvDial<*1>: pppd: H���0�[06][08]��[06][08][01]
WvDial<*1>: pppd: H���0�[06][08]��[06][08][01]
WvDial<*1>: pppd: H���0�[06][08]��[06][08][01]
WvDial<*1>: pppd: H���0�[06][08]��[06][08][01]
WvDial<*1>: pppd: H���0�[06][08]��[06][08][01]
WvDial<*1>: pppd: H���0�[06][08]��[06][08][01]
WvDial<*1>: pppd: H���0�[06][08]��[06][08][01]
WvDial<*1>: pppd: H���0�[06][08]��[06][08][01]
WvDial<*1>: pppd: H���0�[06][08]��[06][08][01]
WvDial<*1>: local  IP address 62.169.123.215
WvDial<*1>: pppd: H���0�[06][08]��[06][08][01]
WvDial<*1>: remote IP address 10.64.64.64
WvDial<*1>: pppd: H���0�[06][08]��[06][08][01]
WvDial<*1>: primary   DNS address 10.11.12.13
WvDial<*1>: pppd: H���0�[06][08]��[06][08][01]
WvDial<*1>: secondary DNS address 10.11.12.14
WvDial<*1>: pppd: H���0�[06][08]��[06][08][01]
WvDial<*1>: pppd: H���0�[06][08]��[06][08][01]
WvDial<*1>: Script /etc/ppp/ip-up run successful
WvDial<*1>: Default route Ok.
sequeira@laptop:~$ WvDial<*1>: warning, can't find address for `www.suse.de`
WvDial<*1>: warning, address lookup does not work
WvDial<*1>: Nameserver (DNS) failure, the connection may not work.
WvDial<*1>: Connected... Press Ctrl-C to disconnect
WvDial<*1>: pppd: H���0�[06][08]��[06][08][01]

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Experimenta usar os do OpenDNS 208.67.222.222 e  208.67.220.220  https://www.opendns.com/start  no file /etc/resolv.conf

Isso dantes dava certo ou nunca chegas-te a ter isso como deve ser? Quando eu usava esse modem uma coisa que ajudava era antes de o iniciar mandar abaixo o Network manager ( #killall NetworkManagerDispatcher &&  killall NetworkManager ).

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Já estou a usar os OpenDNS e também não dá. Assume sempre os mesmos DNS.

Mas, há um problema, sempre que ligo o modem, aparece como usb-storage e não como usbserial.

Já repeti os passos da configuração, mas quando reinicio, continua a ser reconhecido como usb-storage.

Sempre funcionou bem, desde que instalei o Ubuntu, só agora é que começou a ter este comportamento.

Desde inicio que utilizo o software da Vodafone, com os DNS do OpenDNS.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

OOZIE said...

http://www.phoronix.com/forums/showthread.php?t=5675&page=2

If you have a kernel prior to 2.6.20 you can use the udev rule from here.

If you use some later version (>=2.6.20) you may try to turn the power on when the modem is ALREADY connected or do such a trick afterwards:

modprobe -r usb_storage

modprobe -r option usbserial

modprobe -r ahci_hcd uhci_hcd ehci_hcd

modprobe ahci_hcd uhci_hcd ehci_hcd

modprobe usbserial vendor=0x12d1 product=0x1003

*99***1#

find /dev | grep ttyUSB*

wvdial huawei_e220

After that all three /dev/ttyUSB* devices should be available in your /dev directory.

killall NetworkManagerDispatcher

  killall NetworkManager

Algures na Zim. Cheguei a fazer um script para ser mais rápido:

#!/bin/sh
modprobe -r usb_storage
sleep 1
modprobe -r option usbserial
sleep 1
modprobe -r ahci_hcd uhci_hcd ehci_hcd
sleep 2
modprobe ahci_hcd uhci_hcd ehci_hcd
sleep 2
modprobe usbserial vendor=0x12d1 product=0x1003
sleep 3
find /dev | grep ttyUSB*

(Usava kanguru da optimus)

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Como tenho o Kernel 2.6.22 apenas preciso de fazer  killall NetworkManagerDispatcher && killall NetworkManager, é isso?

Eu também uso o Kanguru, mas com o software da Vodafone.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Não. Eu fazia kill ao NetworkManager porque por vezes conectava-me com tudo bem mas não tinha net. O resto tinha que fazer sempre para reconhecer como modem e não como dispositivo de armazenamento. Nunca usei o software da Vodafone.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Neste momento o software da Vodafone não inicia com o modem inserido. Mesmo iniciando pela consola, não aparece nenhum erro. Creio que seja por não o reconhecer como modem.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Neste momento o software da Vodafone não inicia com o modem inserido. Mesmo iniciando pela consola, não aparece nenhum erro. Creio que seja por não o reconhecer como modem.

Estás a falar no driver Vodafone Mobile Card?

Qual é o comando que estás a usar? É que existe um próprio para debug, que de dá muita mais informação

Escreve "sudo vodafone-mobile-connect-card-driver-for-linux-debug", isto se usares Ubuntu.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!


Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.


Entrar Agora