Ir para o conteúdo
  • Revista PROGRAMAR: Já está disponível a edição #57 da revista programar. Faz já o download aqui!

jintonico

[Resolvido] Problema com o '

Mensagens Recomendadas

jintonico    0
jintonico

Boas:

Tou aqui com um problemazeco:  :wallbash:

Tenho este código que me funciona maravilhosamente:

<a title="Empregados deste empregado" href="javascript:carga_empregados('$M4ITEM00$','$M4ITEM01$')" >[+]$M4ITEM5$</a>

Qdo quero construir consoante os valores que vem da base de dados dentro de um IF faço qq coisa do genero:

document.write("<a title='Empregados deste empregado' href='javascript:carga_empregados('$M4ITEM00$','$M4ITEM01$')' >[+]</a>");

Mas o gajo n me reconheçe a partir do 1º parenteses... deve ser um problema da plica... como e q eu resolvo isto?

Tks in advance

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
djthyrax    11
djthyrax

Obrigadão!!  :cheesygrin:

Entretanto num ataque de furia, transformei a ' em unicode, e deu %27 que funcionou... mas essa solução e mto + fixe  :confused:

Isso não é unicode, é a representação em hexadecimal do caracter :P

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!

Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.

Entrar Agora


×

Aviso Sobre Cookies

Ao usar este site você aceita a nossa Política de Privacidade