• Revista PROGRAMAR: Já está disponível a edição #53 da revista programar. Faz já o download aqui!

Cybernavigator

Instalar GeSHi

16 mensagens neste tópico

Boas. Podem-me ajudar a meter o GeSHi num SMF forum v1.1.4?

A ultima versao compativel k havia era po 1.1.3, mas aki no forum eles têm. :hmm:

Any help?!

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Boas!

Vai ao ficheiro package-info.xml (que vem na package) a procura a seguinte linha:

<install for="1.1.1, 1.1.2, 1.1.3">

(ou parecido)

e faz a seguinte alteração:

<install for="1.1.1, 1.1.2, 1.1.3, 1.1.4">

Repara que apenas adicionei , 1.1.4, basicamente é isto que tens de fazer :( (toma atenção à virgula)

Mas não esquecer que PODES querer desinstalar, portanto tens de deixar o MOD preparado para isso, como tal, procura a linha que começa por <uninstall for=" e faz o mesmo que te disse na linha anterior :( Toma em atenção que é o MESMO uninstall do 1.1.3, portanto é nessa linha que tens de adicionar B)

Aqui no fórum funciona porque apenas actualizámos o fórum, isso já estava instalado :D

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Yup, funcou, ty very much.

Eu quando não consegui tive a fazer manualmente, mas quando ia a postar aparecia que a class 'GeSHi' não estava registada :|

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

:S

isso nunca me tinha acontecido..., do GeSHi acho que nunca fiz instalações manuais...

Já agora, o funcionamento do SMF no que respeita a updates é assim:

A.B.x > A.B.y, são updates de segurança, updates "menores". É muito pouco provável afectar MODs.

A.x.z > A.y.w, são updates médios, podem adicionar algumas funcionalidades extra e aqui já começa a afectar MODs e themes...

A.x.y > B.z.w, são os grandes updates, aqui é muito pouco provável que fique alguma coisa compatível :( É o que vai acontecer na próxima versão :(

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Ya, mas por isso é que quando sair a proxima versão vou esperar pelos mods pra essa versão.

Mas já agora, não me sabes explicar pq é que com a instalaçao manual a classe nao é registada?

É que no install nao tem nd que registe a classe.

É um pouco estranho. Acho eu.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

A.x.y > B.z.w, são os grandes updates, aqui é muito provável que fique alguma coisa compatível :P É o que vai acontecer na próxima versão ;)

Não será improvável? :P
0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Também me pareceu k fosse improvável, por isso respondi como se ele não se tive-se enganado... ;)

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

ja agora (sei k n tem nd a ver) de uma vez k se alterou o assunto da thread, ngm me sabe dizer se existe um mod que nao permita double posts?

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Ainda demoram algum tempo a aceitar..., eles têm de ver o source e testar para saberem se é fiável ou não...

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Desde que fike aceite...

Ou entao encher o mail do man ate ele me enviar akilo. ;)

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Tu podes fazer download ;)

Só que instalas isso por tua conta e risco...

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

nops. nao me deixa fazer o download. se csguirx manda ai k eu instalo na boa.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Agora só posso tentar no domingo..., estou agora a arrumar as coisas para sair de fim-de-semana, sorry ;)

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!


Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.


Entrar Agora