• Revista PROGRAMAR: Já está disponível a edição #53 da revista programar. Faz já o download aqui!

metuga

ficheiros php em servidor local

11 mensagens neste tópico

Se calhar é mesmo dúvida de maçarico mas aqui vai:

Ando a testar scripts php que funcionam na perfeição no meu alojamento mas que não abrem no meu servidor local, quando clico no ficheiro php abre uma janela como se eu quisesse fazer o download do ficheiro em vez de o abrir. Isso acontece no Firefox e no IE e testei vários servidores locais entre os quais easyphp e server2go.

É uma chatice porque assim não posso testar os scripts no meu servidor local.

Obrigado pela ajuda

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

pelo que percebi do teu problema, tens duas soluções 1ª - botão direito em cima dos ficheiros > abrir com> escolher programa e ai seleccionas o browser que mais gostas ( acho que assim funciona, mas não tenho a certeza :s).  2ª solução e abrires o browser e meteres o caminho para o ficheiro ex "D:\work\script1.php"

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Como estás a aceder aos ficheiros? Tens o Apache instalado com o PHP configurado?

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Como estás a aceder aos ficheiros? Tens o Apache instalado com o PHP configurado?

acho que ele está a fazer duplo clique no windows :hmm:

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Como estás a aceder aos ficheiros? Tens o Apache instalado com o PHP configurado?

acho que ele está a fazer duplo clique no windows :hmm:

Também me parece, mas deixa-o responder.
0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Como estás a aceder aos ficheiros? Tens o Apache instalado com o PHP configurado?

acho que ele está a fazer duplo clique no windows :hmm:

Também me parece, mas deixa-o responder.

Nada como sentir a confiança das pessoas....

Não, não sou assim tão maçarico. Eu disse que testei vários servidores locais. Agora estou a utilizar o movamp (muito bom diga-se).

Eu acedo obviamente pelo localhost (depois de arrancar com o servidor) na barra de endereço do browser depois ter colocado o ficheiros na pasta respectiva do servidor local.

Alguma coisa me está a escapar, e provavelmente é algo que nada tem a ver com o servidor local já que acontece o mesmo mudando de software.

Ainda cheguei a pensar que seria problema de firewall, uso o comodo, desliguei-o mas continuei a ter o problema.

EDITADO:

Já descobri qual era o problema. No meu alojamento quando preciso de trabalhar com php5 necessito de criar na pasta raiz um ficheiro .htaccess com o seguinte código:

AddHandler application/x-httpd-php5 .php .php4 .php3 .phtml

Eu tinha no servido local o mesmo que que tinha no alojamento...E por isso quando tentava correr um ficheiro php dava-me aquele erro. Apaguei o htaccess no servidor local e tudo ficou a funcionar às mil maravilhas.

Obrigado pela ajuda

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Como estás a aceder aos ficheiros? Tens o Apache instalado com o PHP configurado?

acho que ele está a fazer duplo clique no windows :hmm:

Também me parece, mas deixa-o responder.

Nada como sentir a confiança das pessoas....

Nem respondo...

EDITADO:

Já descobri qual era o problema. No meu alojamento quando preciso de trabalhar com php5 necessito de criar na pasta raiz um ficheiro .htaccess com o seguinte código:

AddHandler application/x-httpd-php5 .php .php4 .php3 .phtml

Eu tinha no servido local o mesmo que que tinha no alojamento...E por isso quando tentava correr um ficheiro php dava-me aquele erro. Apaguei o htaccess no servidor local e tudo ficou a funcionar às mil maravilhas.

Isso é estúpido, o Apache deveria verificar a definição AddHandler antes de adicionar as preferências do .htaccess...
0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
...quando clico no ficheiro php abre uma janela como se eu quisesse fazer o download do ficheiro em vez de o abrir.

Não se trata ou não de confiança, eu apenas respondi tendo em conta isto que tu escreves-te no primeiro post.  :P

Edit: djthyrax, isso não é  no conf que se metia (já la vai algum tempo que nao mexo nisso  :-[)?  :hmm:

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Edit: djthyrax, isso não é  no conf que se metia (já la vai algum tempo que nao mexo nisso  :-[)?  :hmm:

Os AddHandler's estão presentes no httpd.conf sim, mas podem ser acrescentados mais on-the-fly usando .htaccess.
0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

ola djthyrax,

A frase relativamente a confiança que te levou a dizer que nem sequer respondias foi escrita com a intenção de ter alguma piada e não no sentido de ofensa da minha parte. Vejo que não foi entendida assim e por isso peço desculpa. Não era essa a intenção. Bastava ter posto um smiley ao lado da frase e não teria havido malentendido.

Isso é estúpido, o Apache deveria verificar a definição AddHandler antes de adicionar as preferências do .htaccess...

Não vejo bem o que queres dizer com isso mas de qualquer maneira foi exactamente assim que aconteceu. Aquele código que uso no alojamento por alguma razão baralha o servidor local (ou o php). Enfim isso ja me ultrapassa completemente....

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!


Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.


Entrar Agora