• Revista PROGRAMAR: Já está disponível a edição #53 da revista programar. Faz já o download aqui!

cheires

duvida em configuração de Httpd

11 mensagens neste tópico

Olá pessoal.

Estou com um problema na configuração do meu servidor http.

Quando acedo ao index do servidor, e se no browser retirar a parte di index.html, ele faz a listagem de todos os ficheiros e directorias existentes.

Como faço para isso não aocntecer?

Agradeço a todos.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Cria um .htaccess com isto:

Options -Indexes

Isto para o Apache, não conheço outro que traga isso activo por default...

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

procura no ficheiro httpd.conf a directiva DirectoryIndex e verifica se tem o index.html..

ex:  DirectoryIndex index.html index.html.var index.php index.htm

caso não tiver basta acrescentar no fim da linha de DirectoryIndex..

E por fim reinicia o servidor apache.

atenção que isto aplica-se a todos os directorios do servidor web..

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Agora fiquei confuso...

A solução do djthyrax, funcionou em slackware, mas não em debian.

E não entendi muito bem a solução do ht.

Mas de qualquer modo, agradecido aos dois :P

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

No .htaccess, mete (também) isto:

DirectoryIndex index.html

Troca o index.html pelo nome do ficheiro que queres abrir quando o endereço não tem o index.html. :P

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

O problema é que o apache não me lê os ficheiros .htaccess....

Pondo um ficheiro .htaccess com a opção Options -Indexes, deveria funcionar, mas já criei o ficheiro na directoria www e nada, pura e simplesmente não o lê.

como posso contornar esta situação?

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

O problema é que o apache não me lê os ficheiros .htaccess....

Pondo um ficheiro .htaccess com a opção Options -Indexes, deveria funcionar, mas já criei o ficheiro na directoria www e nada, pura e simplesmente não o lê.

como posso contornar esta situação?

Tens que configurar o apache para que as opções utilizadas sejam as do .htaccess (através do AllowOverride).

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Mas o meu apache está configuado, pelo menos tem uma linha no ficheiro de configuração que é

AccessFileName .htaccess

Como o posso configurar atravéz do AllowOverride?

É que também já tentei por uma diresctiva Directory com a directoria base do servidor a www, e também não funcionou.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Se não tiveres nenhuma linha com o AllowOverride então devia funcionar (pois por defeito tem o valor que precisas, ALL). Caso contrário podes colocar o valor ALL.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Exacto, não tenho nenhuma linha com o allowoverride.

Quer dizer, ter tenho, mas essas estão dentro das directivas correspondentes. <directory>  AllowOverride All ( ou None conforme o caso)</Directory>

Não sei mesmo como resolver esta situação.

Obrigado pela ajuda

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!


Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.


Entrar Agora