• Revista PROGRAMAR: Já está disponível a edição #53 da revista programar. Faz já o download aqui!

LuRsT

[Resolvido]Programar PHP em Linux + facil

23 mensagens neste tópico

Boas,

Venho pedir um esclarecimento a todos os programadores de PHP em Linux, é assim eu em Windows edito directamente os ficheiros na pasta do servidor assim só preciso de gravar o ficheiro e actualizar o firefox e já está. Mas o mesmo não acontece em linux e tenho de editar, enviar para o servidor do meu pc por ftp  :eek: e so depois é que actualizo o firefox.

Ora eu queria uma sugestão de como fazer o que eu faço em windows no Linux. Anyone?

Obrigado

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Estamos a falar do localhost, o externo eu sei que tenho mesmo de enviar os ficheiros para o servidor por ftp e não há nada a fazer quanto a isso.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Se utilizares o Lampp, colocas os teus sites em:

/opt/lampp/htdocs/

por exemplo, estás a criar um site com o nome 'ABC', utilizas:

/opt/lampp/htdocs/abc/

... e dentro dessa pasta usas todos os ficheiros do site.

Para visualizá-lo, acedes directamente ao browser:

http://localhost/abc/

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Certo, mad16v eu já sei isso, mas o meu problema é ao editar os ficheiros dessa pasta, não tenho permissoes para editá-los.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Vai à consola e faz:

sudo chmod -R 0777 /opt/lampp/htdocs/ & sudo chown -hR oTeuUsername /opt/lampp/htdocs/

Usa /var/www/ em vez desse path se estiveres a usar o apache2 do apt. :D

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Só consegues modificar nessas pastas com root. Ou dás permissão ao teu user para mexer nessas pastas ou edita-las como root.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Eu pessoalmente opto sempre pelos VHost são muito cómodos e simples e consigo ter vários projectos em simultâneo.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

magician, estás a complicar porquê? O problema do moço é ter que fazer sempre upload por FTP para actualizar o file porque doutra maneira não consegue. Ora, esse problema é exactamente o que o CR_ disse e cuja resolução foi postada por mim. :D

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Precisamente com Vhost não tem esse problema as permiçoes ficam normais e até pode ver os ficheiro pelo "explorer" não vejo onde possa estar a complicação para alem de não ter meter tudo dentro de uma pasta nos confins do sys.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Precisamente com Vhost não tem esse problema as permiçoes ficam normais e até pode ver os ficheiro pelo "explorer" não vejo onde possa estar a complicação para alem de não ter meter tudo dentro de uma pasta nos confins do sys.

Não percebeste o problema. Os vhosts iam funcionar, de facto, mas também podiam ter essa falha. Não foi isso que ele pediu nem resolve da maneira correcta o problema dele. :D

Sem contar que com Vhosts ele teria de alterar o /etc/hosts e adicionar algo do género:

127.0.0.1 o.meu.projecto

:)

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Precisamente com Vhost não tem esse problema as permiçoes ficam normais e até pode ver os ficheiro pelo "explorer" não vejo onde possa estar a complicação para alem de não ter meter tudo dentro de uma pasta nos confins do sys.

Acho que ele estava a assumir que querias criar os VHosts a apontar para pastas dentro da estrutura do apache.

magician, estás a complicar porquê? O problema do moço é ter que fazer sempre upload por FTP para actualizar o file porque doutra maneira não consegue. Ora, esse problema é exactamente o que o CR_ disse e cuja resolução foi postada por mim. :D

Se o VHost aponta para uma pasta do user deixa de existe problemas e é mais simples de gerir do que com mudanças de permissões.

Penso eu de que...

EDIT:

Precisamente com Vhost não tem esse problema as permiçoes ficam normais e até pode ver os ficheiro pelo "explorer" não vejo onde possa estar a complicação para alem de não ter meter tudo dentro de uma pasta nos confins do sys.

Não percebeste o problema. Os vhosts iam funcionar, de facto, mas também podiam ter essa falha. Não foi isso que ele pediu nem resolve da maneira correcta o problema dele. :)

Sem contar que com Vhosts ele teria de alterar o /etc/hosts e adicionar algo do género:

127.0.0.1 o.meu.projecto

:D

É só editar o ficheiro /etc/hosts e fica resolvido (acho que continua mais simples do que andar a mexer nas permissões de pastas de sistema)

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Precisamente com Vhost não tem esse problema as permiçoes ficam normais e até pode ver os ficheiro pelo "explorer" não vejo onde possa estar a complicação para alem de não ter meter tudo dentro de uma pasta nos confins do sys.

Não percebeste o problema. Os vhosts iam funcionar, de facto, mas também podiam ter essa falha. Não foi isso que ele pediu nem resolve da maneira correcta o problema dele. :D

Sem contar que com Vhosts ele teria de alterar o /etc/hosts e adicionar algo do género:

127.0.0.1 o.meu.projecto

:)

/etc/hosts só é preciso mexer se quizeres ter mais de uma pasta online de cada vez, no caso de ser apenas uma não é preciso mexer nisso.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Usar algo para uma coisa que não é o seu propósito, é um erro, e é isso que iria fazer com a vhost. Esta é a minha opinião. :D

Mas já que querem alternativas a UM comando na shell, podem fazer sub-dir mapping, redireccionando, por exemplo, o URI /botnet/ para a pasta /home/lurst/botnet/ :)

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Usando a instalação dos repos, basta editar o /etc/apache2/apache2.conf e pôr lá:

Alias /botnet/ "/home/lurst/botnet/"

<Directory "/home/lurst/botnet/">
    Options Indexes MultiViews
    AllowOverride None
    Order allow,deny
    Allow from all
</Directory>

Isto era o que eu usava no Windows, e sempre funcionou. :)

Como estás a usar o LAMP, provavelmente o ficheiro é o httpd.conf, numa subdirectoria do /opt/lampp/ (provavelmente a conf).

EDIT: Em relação ao usar o botnet como exemplo, é porque desconfio que seja esse o motivo. :D

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Resolvi usar o truque do djthyrax e funcionou as mil maravilhas, obrigado magician por me mostrares o vhost, mas nao e bem o que eu queria.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Usar algo para uma coisa que não é o seu propósito, é um erro, e é isso que iria fazer com a vhost. Esta é a minha opinião. :)

Mas já que querem alternativas a UM comando na shell, podem fazer sub-dir mapping, redireccionando, por exemplo, o URI /botnet/ para a pasta /home/lurst/botnet/ :D

Isso é soluções há preguiçoso lol :D

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Usar algo para uma coisa que não é o seu propósito, é um erro, e é isso que iria fazer com a vhost. Esta é a minha opinião. :)

Mas já que querem alternativas a UM comando na shell, podem fazer sub-dir mapping, redireccionando, por exemplo, o URI /botnet/ para a pasta /home/lurst/botnet/ :D

Isso é soluções há preguiçoso lol :D

Não, dá quase o mesmo trabalho que os vhosts, excepto a parte de alterar o /etc/hosts. O mapping que ele vai fazer é, de facto, usada para aquilo que foi programada, ao contrário de um vhost. :)
0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Vocês complicam muito! A solução mais fácil e rápida para o problema é um link simbólico!

Ex: Tens a pasta web na tua home e fazes: "sudo ln -s /home/user/web /var/www/web" isto para o apache2. E no browser fazes: "localhost/web".

Não te esqueças de dar permissões aos ficheiros da pasta web.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Vocês complicam muito! A solução mais fácil e rápida para o problema é um link simbólico!

Ex: Tens a pasta web na tua home e fazes: "sudo ln -s /home/user/web /var/www/web" isto para o apache2. E no browser fazes: "localhost/web".

Não te esqueças de dar permissões aos ficheiros da pasta web.

Isso não é crossplatform :D </desculpas>

Anyway, o que tu fizeste mpeixoto, tem a mesma dificuldade que aquele comando que postei lá atrás e faz o mesmo que esta última solução que dei. :)

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!


Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.


Entrar Agora