• Revista PROGRAMAR: Já está disponível a edição #53 da revista programar. Faz já o download aqui!

metRo_

Visual C++ 2008 Express Edition - Duvida

7 mensagens neste tópico

Boa tarde.

Iniciei-me à pouco em Visual C++(ja possuía conhecimentos em C++) e para isso instalei o Visual C++ 2008 Express Edition.

Fiz uma pequena aplicação(calculadora) e sempre que envio o executável para alguém nunca o conseguem abrir sendo o erro o da imagem que está em anexo e deixo também o executável em anexo.

Já me disseram que pode ser incompatibilidade de .NET framework, se assim for há possibilidade de compilar o projecto para funcionar em todos os .NET framework?!

Abraços

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Nunca usei o VC++ portanto não tenho a certeza no que digo.

Esse erro é provavelmente devido a dlls.

Saca esta aplicação, com ela consegues ver o que depende a tua aplicação. Por exemplo a mim diz que falta o MSJAVA.DLL, o problema provavelmente será esse. Ou seja terás que distribuir essa dll juntamente com o executável.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

É provável que a pessoa a quem envias não tenha a .net framework 3

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Estive a procura e não encontrei nenhuma dll dentro da pasta do projecto.

Em anexo coloquei agora toda a pasta Debug, estavam la mais dois ficheiros não sei se ajuda ou não.

Quanto ao programa está em anexo um print não percebi muito bem como analisar aquilo visto que deu uma lista muito grande.

Se alguém já tiver instalado esta versão do Visual deixo aqui o projecto: http://www.puntoparquets.com/metro/calc.rar

É provável que a pessoa a quem envias não tenha a .net framework 3

Se fosse este o problema havia como compilar para funcionar nas outras versões?!

Abraços e obrigado pelas respostas :(

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Hmm, não é da framework, pois eu tenho-a instalada, e ele dá esse mesmo erro.

Podes é usar o VS2005 em vez do 2008

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Não podes fazer o teu programa sem usar .NET?

Não sei :S

Como disse estou-me a iniciar por isso pedi a vossa ajuda....

Mas senão é da framework isto deve ter maneira de resolver...

Hmm, não é da framework, pois eu tenho-a instalada, e ele dá esse mesmo erro.

Podes é usar o VS2005 em vez do 2008

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!


Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.


Entrar Agora