• Revista PROGRAMAR: Já está disponível a edição #53 da revista programar. Faz já o download aqui!

Cyrus

[AJUDA] Kanguru (Huawei_E220) + Backtrack

6 mensagens neste tópico

Boas malta :)

Queria pedir a vossa ajuda, para ver se consigo colocar o modem do kanguru a funcionar com o Backtrack CDLive. O nosso da PTSec, o placker, deu-me esta dica:

Insere o cartão

Mas antes de inserires o cartão, escreve num terminal o seguinte:

tail -f /var/log/messagesAssim, poderemos ver o que se passa quando inserirmos o cartão 3G no slot PCMCIA.

Deve aparecer na consola uma série de texto, qualquer coisa deste género:

Jun 21 13:35:52 localhost kernel: [17191910.432000] pccard: CardBus card inserted into slot 1
Jun 21 13:35:52 localhost kernel: [17191910.432000] PCI: Enabling device 0000:06:00.0 (0000 -> 0002)
Jun 21 13:35:52 localhost kernel: [17191910.432000] ACPI: PCI Interrupt 0000:06:00.0[A] -> Link [LNKD] -> GSI 9 (level, low) -> IRQ 9
Jun 21 13:35:52 localhost kernel: [17191910.432000] ohci_hcd 0000:06:00.0: OHCI Host Controller
Jun 21 13:35:52 localhost kernel: [17191910.432000] ohci_hcd 0000:06:00.0: new USB bus registered, assigned bus number 3
Jun 21 13:35:52 localhost kernel: [17191910.432000] ohci_hcd 0000:06:00.0: irq 9, io mem 0x26000000
Jun 21 13:35:52 localhost kernel: [17191910.520000] hub 3-0:1.0: USB hub found
Jun 21 13:35:52 localhost kernel: [17191910.520000] hub 3-0:1.0: 1 port detectedJun 21 13:35:52 localhost kernel: [17191910.624000] PCI: Enabling device 0000:06:00.1 (0000 -> 0002)
Jun 21 13:35:52 localhost kernel: [17191910.624000] ACPI: PCI Interrupt 0000:06:00.1[b] -> Link [LNKD] -> GSI 9 (level, low) -> IRQ 9
Jun 21 13:35:52 localhost kernel: [17191910.624000] ohci_hcd 0000:06:00.1: OHCI Host Controller
Jun 21 13:35:52 localhost kernel: [17191910.624000] ohci_hcd 0000:06:00.1: new USB bus registered, assigned bus number 4
Jun 21 13:35:52 localhost kernel: [17191910.624000] ohci_hcd 0000:06:00.1: irq 9, io mem 0x26001000
Jun 21 13:35:52 localhost kernel: [17191910.708000] hub 4-0:1.0: USB hub found
Jun 21 13:35:52 localhost kernel: [17191910.708000] hub 4-0:1.0: 1 port detectedJun 21 13:35:53 localhost kernel: [17191911.432000] usb 3-1: new full speed USB device using ohci_hcd and address 2
Jun 21 13:35:53 localhost kernel: [17191911.648000] option 3-1:1.0: Option 3G data card converter detected
Jun 21 13:35:53 localhost kernel: [17191911.648000] usb 3-1: Option 3G data card converter now attached to ttyUSB0
Jun 21 13:35:53 localhost kernel: [17191911.652000] option 3-1:1.1: Option 3G data card converter detected
Jun 21 13:35:53 localhost kernel: [17191911.652000] usb 3-1: Option 3G data card converter now attached to ttyUSB1
Jun 21 13:35:53 localhost kernel: [17191911.656000] option 3-1:1.2: Option 3G data card converter detected
Jun 21 13:35:53 localhost kernel: [17191911.656000] usb 3-1: Option 3G data card converter now attached to ttyUSB2

No meu caso, interessa-me o dispositivo ttyUSB0. isto não deve variar.

Após termos feito isto, está na altura de configurarmos a ligação.

Escreve na consola

sudo pppconfig

Depois, escolhe a opção para criar uma nova ligação, com os seguintes dados: (poderão não ser pedidos na ordem que escrevi):

Dynamic DNS
PAP Protocol
Username é o numero do cartão, password é o PIN
O número de telefone a marcar é *99***1#

O programa vai dizer que pode detectar automaticamente a porta onde o modem está ligado; no meu caso não detectou; como tal usei o dispositivo /dev/ttyUSB0 (case sensitive)

Guardar os dados, fazer quit, the end.

Para activares a ligação:

$ pon 'nome da ligacao'

Para desactivar a ligação:

$ poff 'nome da ligacao'

Para ejectar o 3G card:

Código:

$ sudo cardctl eject

É extremamente importante que se execute este último comando antes de se sacar a placa; quem não fizer isto arrisca-se a danificar a placa.

Pois bem, o comando "pppconfig" é desconhecido pelo Backtrack, por isso tentei dar a volta á situação por usar o wizard que o Backtrack traz para fazer a ligação da net. Penso que preenchi os campos bem, mas quando faço o Connect, aparece-me uma mensagem de erro a dizer que o dispositivo ttyUSB0 não é reconhecido. :hmm:

O que faço, alguma sugestão???

Cumps,

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Aconselho a veres este how-to: http://www.techzonept.com/showthread.php?t=174805

Atenta na parte da identificação do dispositivo e depois se não tiveres acesso aos comandos que lá usam para configurar experimenta com o wizard do Blacktrack.

Roger that...

Vou tentar, depois digo alguma coisa. Obrigado pela ajuda ;)

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Boas malta, tentei por em prática as dicas que o Prodigy da techzonept deu para por a funcionar o modem por USB da Kanguru. Tentei no Backtrack a ultima versão.

Primeiro fiz o tal

tail -f /var/log/messages

bt ~ # tail -f /var/log/messages
Aug 24 16:21:44 (none) gconfd (root-6110): Resolved address "xml:readonly:/usr/local/etc/gconf/gconf.xml.defaults" to a read-only configuration source at position 2
Aug 24 16:22:14 (none) gconfd (root-6110): GConf server is not in use, shutting down.
Aug 24 16:22:14 (none) gconfd (root-6110): Exiting
Aug 24 16:29:33 (none) kernel: usb 1-3: USB disconnect, address 3
Aug 24 16:29:33 (none) kernel: option1 ttyUSB0: GSM modem (1-port) converter now disconnected from ttyUSB0
Aug 24 16:29:33 (none) kernel: option 1-3:1.0: device disconnected
Aug 24 16:29:33 (none) kernel: option1 ttyUSB1: GSM modem (1-port) converter now disconnected from ttyUSB1
Aug 24 16:29:33 (none) kernel: option 1-3:1.1: device disconnected
Aug 24 16:29:33 (none) kernel: option1 ttyUSB2: GSM modem (1-port) converter now disconnected from ttyUSB2
Aug 24 16:29:33 (none) kernel: option 1-3:1.2: device disconnected

depois liguei o modem, os dois conectores usb e apareceu esta mensagem:

Aug 24 16:30:17 (none) kernel: usb 1-3: new full speed USB device using ohci_hcd and address 4
Aug 24 16:30:17 (none) kernel: usb 1-3: configuration #1 chosen from 1 choice
Aug 24 16:30:17 (none) kernel: usb-storage: device ignored
Aug 24 16:30:17 (none) kernel: option 1-3:1.0: GSM modem (1-port) converter detected
Aug 24 16:30:17 (none) kernel: usb 1-3: GSM modem (1-port) converter now attached to ttyUSB0

Depois:

find /dev | grep ttyUSB*

E deu-me esta mensagem

bt ~ # find /dev | grep ttyUSB*
/dev/.udev/db/class@tty@ttyUSB0

Por fim quando faço isto:

rmmod usb-storage && modprobe usbserial vendor=0x12d1 product=0x1003

Deu-me este erro

ERROR: Module usb_storage is in use

O que é que faço? Alguma dica?

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Não é #rmmod usb-storage mas sim #rmmod usb_storage  (de hífen para under score _)

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

ERROR: Module usb_storage is in use

O que é que faço? Alguma dica?

Pa no ubuntu isso tb me acontece mas dps avança e liga a internet normalmente.

O metodo k eu uso funciona no ubuntu livecd agora no backtrack n sei

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!


Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.


Entrar Agora