• Revista PROGRAMAR: Já está disponível a edição #53 da revista programar. Faz já o download aqui!

M.offspring.R

cedega e Steam

16 mensagens neste tópico

Boa tarde.

Tenho aqui um pequeno problema. Tenho instalado o cedega, e como tal decidi instalar o steam (Counter Strike: Source + Day Of defeat: Source). O que acontece é, eu instalei o cedega e o steam na boa, inicio o steam sem nenhum problema. O problema chega quando pretendo restaurar o backup feito ao steam (para não ter que sacar tudo de novo), ele inicia, digo que quero restaurar e depois.. puuff, desaparece este menu de selecção e o steam que esta previamente a correr. Qual será o problema?

Eu ai há tempos consegui jogar CS em Linux, com frames entre 80 e 90, mas agora está difícil voltar a jogar em Linux...

Aguardo uma resposta.

Cump.

M.offspring.R

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Corre pela consola e vê o log. Mete aqui.

Já tentaste compilar o wine e ver a diferença?

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Bem este problema já foi resolvido, após inumeras tentativas lá consegui resolver.

Agora surgio outra cena... Aproveitando este topic aberto, ca vai:

Fui a consola e escrevi o glxinfo |grep direct (para ver se tinha acelaracao 3D, no qual obtive um resultado positivo (ficando com a seguinte mensagem direct rendering: Yes). Até aqui tudo bem. acontece que quando vou pra jogar CS só tenho frames na ordem das 10, chegando mesmo por bloquear o pc... Já refiz os testes de cedega e em tudo obtive o "passed". Agora pergunto, qual será desta vez o problema?

Será das gráfica? Será das drivers? Será alguma opção no cedega?

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

A mensagem de erro é esta:

erro_css.png

Antes ainda dava para entrar no menu do jogo, agora nem isso dá....

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

O backup reparado foi usado no mesmo SO, ou instalaste o mesmo ou outro?

Tenta instalar de novo. Podes aproveitar alguns files do Day Of defeat: Source e do Counter Strike: Source (aqueles do motor do jogo para evitar tráfego).

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Este backup foi feito em windows em Janeiro deste ano e, até a presente data, não vi mais nenhuma actualização feita.

O mais curioso é que ha semanas atrás, fiz este mesmo processo, restaurando o backup, e tinha frames entre 80-90, hoje é que isto anda feito chalado.... Deve ser do calor...

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Bem hoje acabei por instalar tudo de novo e decidi queimar uns quantos MB a sacar o jogo da net pelo steam, pode ser que de assim... Aproveito e faço novo backup.

Quando acabar o down já digo o resultado....

Update: Ja saquei o jogo da net, mas mesmo assim nada... entra no jogo, fica o menu a preto e daí não passa... mas que cena, porque é que ai ha tempos deu e agora não??

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Ora bem isso aconteceu-me c o Condition Zero, os meus problemas tinha sido instalar as novas drivers da ati, mas tb tinha instalado o suporte para antialising e agp, s n estou em erro. E tinha isso activo pelo catalyst. Ora bem o linux, n s da bem c o catalyst e por isso entrava no jogo e mais nada, tudo a preto, e a trabalhar tb a 2fps.

Soluçao desactivei as opçoes k tinha seleccionado, e no cedega mudei de XrandR, para Xdivmode, e agora ja da.

Apesar de n ser o mesmo jogo, pode ser k seja isso. Mais uma vez digo ATI+LINUX n bota :D

por isso Nvidia e sempre boa opçao

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Ok.

Thanks pela ajuda, no fim de semana verifico isso.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Eu jogo CS pelo wine(0.9.33) no ubuntu. tenho uma ati x1600pro e saco os mesmos fps que saco no windows, mas no windows os fps colam nos 99.9fps, no ubuntu ás vezes descem para os 85fps, e variam entre os 85 e 100fps. Mas no ubuntu tenho loss e choke sempre a 0, enquanto que no windows ás vezes nem consigo jogar, já cheguei a ter choke de 100!!!!!!!!! no windows. A minha gráfica nunca me deu problemas e é bastante simples de configurar, ao contrário do que dizem. Até a minha velhinha 9200se nunca me deu problemas no ubuntu. Eu sei que nvidia para linux é melhor, mas eu nunca tive problemas com a ati, e é uma pena os portateis dell só terem nvidia ou onboard intel. Pois estou a pensar em comprar um mas queria ati.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Até a minha velhinha 9200se nunca me deu problemas no ubuntu.

Dizes isso porque só usas 2D com ela. Até o suporte já acabou para ela...

Além disso a ATI ainda nem suporta AIGLX.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Olha e assim, s keres suporte para placa grafica o melhor mesmo comprares Nvidia, as placas ati em linux n sao boa aposta, pk a amd n insveste tanto cm a nvidia em criar suporte para Linux, essa e uma razao pela kual a nvidia esta sempre um passo a frente da ATI. Apesar de kd a ati passou a fazer parte da amd, s ter ouvido dizer k ia sofrer um grande choque a realidade e k so a nivel de windows e k a assistencia e boa.

Por enkuanto kem kiser ter cedega, o melhor e optar-se pela Nvidia. E dou ja aki um exemplo, jogo cm o age of mythology nao funciona em ATI, no cedega, pk o cedega n consegue interpretar a placa cm sendo uma ati, muda-lhe o nome e da cm sendo uma placa n suportada. Este e so um exemplo. Kem kiser aplicaçoes n nativas para linux, k usem grafismo, usem outra placa. Para finalizar dou o exemplo do UT2004, nativo para linux, as vezes bate mal por causa da placa. Em nvidia, nunca o vi a ter problemas.

Conclusao Linux + ATI = n e mau

LINUX+Nvidia = melhor resultado

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Ora bem isso aconteceu-me c o Condition Zero, os meus problemas tinha sido instalar as novas drivers da ati, mas tb tinha instalado o suporte para antialising e agp, s n estou em erro. E tinha isso activo pelo catalyst. Ora bem o linux, n s da bem c o catalyst e por isso entrava no jogo e mais nada, tudo a preto, e a trabalhar tb a 2fps.

Soluçao desactivei as opçoes k tinha seleccionado, e no cedega mudei de XrandR, para Xdivmode, e agora ja da.

Apesar de n ser o mesmo jogo, pode ser k seja isso. Mais uma vez digo ATI+LINUX n bota :)

por isso Nvidia e sempre boa opçao

Eu tinha essa opção de origem e não deu...  :down:

Estou vendo que se quiser jogar um pouco tenho que ir para o windows... Só jogo a 3 jogos (TMN, CSS e AA), e mesmo assim nenhum deles da em Linux....

Por isso a solução é essa.. ir pra Windows quando quiser jogar.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Aproveitando o topic.

Acabei de instalar o Steam e Counter Strike pelo wine. Entro no jogo na boa, mas ao jogar é que há problema... Antes da ronda começar tenho FPS na ordem dos 60, quando começa mesmo a ronda, os FPS caiem pra os 10 (por vezes até menos). Alguém sabe o que posso fazer?

Já andei alterando a versão do Windows para win98, win2000 e winXP, mas mesmo assim nada...

Aguardo uma resposta.

Cump.

M.offspring.R

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!


Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.


Entrar Agora