• Revista PROGRAMAR: Já está disponível a edição #53 da revista programar. Faz já o download aqui!

djthyrax

Grub Error 17: Cannot mount selected partition

13 mensagens neste tópico

Boas. Acabei de instalar o meu ubuntuzinhoinho quando tento fazer boot e o Grub diz isto: Grub Error 17: Cannot mount selected partition

Já googlei e as soluções que encontrei foi mesmo instalar o Lilo. A minha questão é: Como meto o Lilo?

Cumps. :P

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

o teu disco é SATA?

isso não tem a ver com a falta das drives para SATA compiladas no kernel?

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Sim, é SATA. Não, não é falta dos drivers, eu no grub consigo aceder ao /...

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Tive o mesmo problema, e a solução foi por o disco onde tá o Linux como Master, e reinstalar o Linux (instalando o Grub no disco onde tá o Linux)

Eu tinha o Disco Master com o Win XP (file system NTFS) e como o GRUB ia para a MBR do disco principal dava esse erro.

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Tive o mesmo problema, e a solução foi por o disco onde tá o Linux como Master, e reinstalar o Linux (instalando o Grub no disco onde tá o Linux)

Eu tinha o Disco Master com o Win XP (file system NTFS) e como o GRUB ia para a MBR do disco principal dava esse erro.

Eu resolvi facilmente isto. Como estava a escolher manualmente o disco a fazer boot, em vez de ser (hd3,1) como tinha sido reconhecido, passei a usar (hd0,1) e neste momento estou no ubuntu. :thumbsup:
0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Tive o mesmo problema, e a solução foi por o disco onde tá o Linux como Master, e reinstalar o Linux (instalando o Grub no disco onde tá o Linux)

Eu tinha o Disco Master com o Win XP (file system NTFS) e como o GRUB ia para a MBR do disco principal dava esse erro.

Eu resolvi facilmente isto. Como estava a escolher manualmente o disco a fazer boot, em vez de ser (hd3,1) como tinha sido reconhecido, passei a usar (hd0,1) e neste momento estou no ubuntu. ;)

entao ficaste sem oportunidade de escolher o so com k keres entrar? podias ter usado o super grub disk

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

entao ficaste sem oportunidade de escolher o so com k keres entrar? podias ter usado o super grub disk

Nop, alterei foi a configuração do Grub. Ele estava a tentar bootar o disco que na instalação foi reconhecido como hd3,1 e na "realidade" quando entrava no disco era hd0,1 ;) Foi só alterar isso e ficou tudo 5 estrelas ;)
0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

entao ficaste sem oportunidade de escolher o so com k keres entrar? podias ter usado o super grub disk

Nop, alterei foi a configuração do Grub. Ele estava a tentar bootar o disco que na instalação foi reconhecido como hd3,1 e na "realidade" quando entrava no disco era hd0,1 ;) Foi só alterar isso e ficou tudo 5 estrelas ;)

tao fizeste a mesma coisa k abrir o cfdisk e definir a partiçao de boot?

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

tao fizeste a mesma coisa k abrir o cfdisk e definir a partiçao de boot?

er, limitei-me a alterar o /boot/grub/menu.lst
0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

tao fizeste a mesma coisa k abrir o cfdisk e definir a partiçao de boot?

er, limitei-me a alterar o /boot/grub/menu.lst

axo k e a mm coisa pk o cfdisk ia editar o grub e por direito:P

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

tao fizeste a mesma coisa k abrir o cfdisk e definir a partiçao de boot?

er, limitei-me a alterar o /boot/grub/menu.lst

axo k e a mm coisa pk o cfdisk ia editar o grub e por direito:P

Acho que o problema era esse mesmo porque quando actualizei o kernel, ele adicionou-me outra entrada, outra vez com (hd2,1).

Observa a minha situação:

IDE Primary Master -> Windows XP

IDE Primary Slave -> Windows XP (outra instalação)

SATA (4º) -> Ubuntu

Ou seja, analisando por este prisma, o Ubuntu estava no (hd2,x). Mas, a minha board (ASUS A8N-SLI Deluxe), quando vou ao boot menu e escolho o disco que quero bootar, ele move esse disco para primeiro lugar. Ou seja, quando eu escolhia o disco SATA, a ordem ficava:

SATA (4º) -> Ubuntu

IDE Primary Master -> Windows XP

IDE Primary Slave -> Windows XP (outra instalação)

(o SATA ia ficar como (hd0,x), o master como (hd1,x) e o slave como (hd2,x))

E se eu escolhesse a outra instalação do XP:

IDE Primary Slave -> Windows XP (outra instalação)

IDE Primary Master -> Windows XP

SATA (4º) -> Ubuntu

Ou seja, o disco que eu escolho fica como (hd0,x) :D

PS: Eu considerei que o Grub começa a contar do 0 e não do 1. Se não for assim, avisem-me que eu altero. :)

0

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!


Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.


Entrar Agora